aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2010-02-08 09:32:34 -0500
committerRalph Amissah <ralph@amissah.com>2010-02-08 09:32:34 -0500
commita1d959389ae0b9ed9b5cc310789ea872554528ae (patch)
tree50de4a486ccfcefa1df57f97a43f92da479b45e8
parentdebian/changelog (diff)
parentlittle brother, cory doctorow, skin, & copyright detail (diff)
Merge branch 'upstream' into debian/sid
-rw-r--r--COPYRIGHT2
-rw-r--r--data/v1/README2
-rw-r--r--data/v1/samples/_sisu/image/little_brother_doctorow.pngbin0 -> 7159 bytes
-rw-r--r--data/v1/samples/_sisu/skin/doc/skin_little_brother.rb88
-rw-r--r--data/v1/samples/free_as_in_freedom.richard_stallman_crusade_for_free_software.sam_williams.sst4
-rw-r--r--data/v1/samples/little_brother.cory_doctorow.sst4
6 files changed, 94 insertions, 6 deletions
diff --git a/COPYRIGHT b/COPYRIGHT
index 72b02e5..1d61838 100644
--- a/COPYRIGHT
+++ b/COPYRIGHT
@@ -108,7 +108,7 @@ Text: Little Brother
URL: <http://craphound.com/littlebrother>
Author: Cory Doctorow
URL: <http://craphound.com>
-Copyright: Cory Doctorow
+Copyright: Cory Doctorow, 2008
License:
URL: <http://creativecommons.org/licenses/by-nc-sa/3.0/>
diff --git a/data/v1/README b/data/v1/README
index da80e1e..6b7f388 100644
--- a/data/v1/README
+++ b/data/v1/README
@@ -69,7 +69,7 @@ maintained and often that the works be used only non-commercially
URL: <http://craphound.com/littlebrother>
Author: Cory Doctorow
URL: <http://craphound.com>
- Copyright: Cory Doctorow
+ Copyright: Cory Doctorow, 2008
License:
URL: <http://creativecommons.org/licenses/by-nc-sa/3.0/>
diff --git a/data/v1/samples/_sisu/image/little_brother_doctorow.png b/data/v1/samples/_sisu/image/little_brother_doctorow.png
new file mode 100644
index 0000000..af106a1
--- /dev/null
+++ b/data/v1/samples/_sisu/image/little_brother_doctorow.png
Binary files differ
diff --git a/data/v1/samples/_sisu/skin/doc/skin_little_brother.rb b/data/v1/samples/_sisu/skin/doc/skin_little_brother.rb
new file mode 100644
index 0000000..576aa4f
--- /dev/null
+++ b/data/v1/samples/_sisu/skin/doc/skin_little_brother.rb
@@ -0,0 +1,88 @@
+=begin
+ * Name: SiSU - Simple information Structuring Universe - Structured information, Serialized Units
+ * Author: Ralph Amissah
+ * http://www.jus.uio.no/sisu
+ * http://www.jus.uio.no/sisu/SiSU/download
+ * Description: Skin prepared for Little Brother, Cory Doctorow
+ * License: Same as SiSU see http://www.jus.uio.no/sisu
+ * Notes: Site default appearance variables set in defaults.rb
+ Generic site wide modifications set here scribe_skin.rb, and this file required by other "scribes" instead of defaults.rb
+=end
+module SiSU_Viz
+ require SiSU_lib + '/defaults'
+ class Skin
+ #% path
+ def path_root # the only parameter that cannot be changed here
+ './sisu/'
+ end
+ def path_rel
+ '../'
+ end
+ #% url
+ def url_home
+ 'http://craphound.com/littlebrother'
+ end
+ def url_txt # text to go with url usually stripped url
+ 'craphound.com/littlebrother'
+ end
+ #% color
+ def color_band1
+ '"#ffffff"'
+ end
+ #% text
+ def text_hp
+ 'craphound.com/littlebrother'
+ end
+ def text_home
+ 'Little Brother'
+ end
+ #% icon
+ def icon_home_button
+ 'little_brother_doctorow.png'
+ end
+ def icon_home_banner
+ icon_home_button
+ end
+ #% banner
+ def banner_home_button
+ %{<table summary="home button" border="0" cellpadding="3" cellspacing="0"><tr><td align="left" bgcolor=#{color_white}><a href="#{url_home}">#{png_home}</a></td></tr></table>\n}
+ end
+ def banner_home_and_index_buttons
+ %{<table><tr><td width="20%"><table summary="home and index buttons" border="0" cellpadding="3" cellspacing="0"><tr><td align="left" bgcolor=#{color_white}><a href="#{url_home}" target="_top">#{png_home}</a></td><td width="40%"><center><table summary="buttons" border="1" cellpadding="3" cellspacing="0"><tr><td align="center" bgcolor="#f1e8de"><font face="arial" size="2"><a href="toc.html" target="_top">&nbsp;This&nbsp;text&nbsp;sub-&nbsp;<br />&nbsp;Table&nbsp;of&nbsp;Contents&nbsp;</a></font>#{table_close}</center></td><td width="20%">&nbsp;#{table_close}}
+ end
+ def banner_band
+ %{<table summary="band" border="0" cellpadding="3" cellspacing="0"><tr><td align="left" bgcolor=#{color_white}><a href="#{url_home}" target="_top">#{png_home}</a>#{table_close}}
+ end
+ #% credits
+ def credits_splash
+ %{<table summary="credits" align="center" bgcolor="#ffffff"><tr><td><font color="black"><center>
+<a href="http://craphound.com/littlebrother">The author's original pdf is available</a> at<br /><a href="http://craphound.com/littlebrother">craphound.com/littlebrother</a><br />
+available at<br /><a href="http://www.amazon.com/Little-Brother-Cory-Doctorow/dp/B002IT5OMA">Amazon.com</a> and <br />
+<a href="http://search.barnesandnoble.com/Little-Brother/Cory-Doctorow/e/9780765319852">Barnes & Noble</a><br />
+This book is Copyright Cory Doctorow © 2008<br />
+Under a Creative Commons License,<br />
+Attribution-NonCommercial-NoDerivs 3.0:<br />
+* Attribution — You must attribute the work in the manner specified by the author or licensor (but not in any way that suggests that they endorse you or your use of the work);<br />
+* Noncommercial. You may not use this work for commercial purposes;<br />
+* Share Alike - If you alter, transform, or build upon this work, you may distribute the resulting work only under the same or similar license to this one.
+<br />
+&lt;<a href="http://creativecommons.org/licenses/by-nc-sa/3.0/">http://creativecommons.org/licenses/by-nc-sa/3.0/</a>&gt;<br />
+</center></font></td></tr></table>}
+ end
+ end
+ class TeX
+ def header_center
+ "\\chead{\\href{#{@vz.url_home}}{craphound.com/littlebrother}}"
+ end
+ def home_url
+ "\\href{#{@vz.url_home}}{craphound.com/littlebrother}"
+ end
+ def home
+ "\\href{#{@vz.url_home}}{Little Brother}"
+ end
+ def owner_chapter
+ "Document owner details"
+ end
+ end
+end
+__END__
diff --git a/data/v1/samples/free_as_in_freedom.richard_stallman_crusade_for_free_software.sam_williams.sst b/data/v1/samples/free_as_in_freedom.richard_stallman_crusade_for_free_software.sam_williams.sst
index 74b90a4..3509c45 100644
--- a/data/v1/samples/free_as_in_freedom.richard_stallman_crusade_for_free_software.sam_williams.sst
+++ b/data/v1/samples/free_as_in_freedom.richard_stallman_crusade_for_free_software.sam_williams.sst
@@ -68,7 +68,7 @@ One final note: this is a work of journalism, but it is also a work of technical
Please address comments and questions concerning this book to the publisher:
-poem{
+group{
O'Reilly & Associates, Inc.
1005 Gravenstein Highway North
@@ -77,7 +77,7 @@ poem{
(707) 829-0515 (international/local)
(707) 829-0104 (fax)
-}poem
+}group
There is a web page for this book, which lists errata, examples, or any additional information. The site also includes a link to a forum where you can discuss the book with the author and other readers. You can access this site at:
diff --git a/data/v1/samples/little_brother.cory_doctorow.sst b/data/v1/samples/little_brother.cory_doctorow.sst
index 6cb1597..3a2df5e 100644
--- a/data/v1/samples/little_brother.cory_doctorow.sst
+++ b/data/v1/samples/little_brother.cory_doctorow.sst
@@ -1,4 +1,4 @@
-% SiSU 0.72
+% SiSU 1.0
@title: Little Brother
@@ -10,7 +10,7 @@
@level: break=1
-% @skin: skin_little_brother
+@skin: skin_little_brother
@links: { Little Brother home }http://craphound.com/littlebrother
{ Little Brother by Cory Doctrow @ SiSU }http://www.jus.uio.no/sisu/little_brother.cory_doctrow