aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100755
index 0000000..ad4bd50
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,24 @@
+#!/usr/bin/env -S nix-shell --pure
+#!nix-shell -i bash
+{ pkgs ? import <nixpkgs> {} }:
+let
+in pkgs.mkShell {
+ buildInputs = with pkgs; [
+ nix
+ bundler
+ bundix
+ #ruby
+ #rubyPackages.rake
+ #rubyPackages.sqlite3
+ #rubyPackages.thor
+ ruby_3_1
+ rubyPackages_3_1.rake
+ rubyPackages_3_1.sqlite3
+ rubyPackages_3_1.thor
+ sqlite
+ unzip
+ xz
+ zip
+ #texlive-combined-full
+ ];
+}