aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-03-06 18:27:39 -0500
committerRalph Amissah <ralph@amissah.com>2013-03-06 18:27:39 -0500
commit316055f08aa901df87cde8e343a8e2137e9929b5 (patch)
treeeb372f00038de0f1c34a2e1564fca4b3d8d15d39
parentdebian/changelog (4.0.10-1) (diff)
parentv4: emacs, sisu-mode.el, version touch (diff)
Merge tag 'sisu_4.0.11' into debian/sid
SiSU 4.0.11
-rw-r--r--bin/sisu28
-rw-r--r--data/doc/sisu/CHANGELOG_v418
-rw-r--r--data/sisu/v4/conf/editor-syntax-etc/emacs/sisu-mode.el2
-rw-r--r--data/sisu/v4/v/version.yml6
-rw-r--r--lib/sisu/v4/html_format.rb2
-rw-r--r--lib/sisu/v4/options.rb19
-rw-r--r--lib/sisu/v4/shared_sisupod_source.rb10
-rw-r--r--lib/sisu/v4/sysenv.rb5
8 files changed, 46 insertions, 44 deletions
diff --git a/bin/sisu b/bin/sisu
index b7156f43..daa2a48d 100644
--- a/bin/sisu
+++ b/bin/sisu
@@ -82,30 +82,24 @@ WOK
'v4'
end
end
-#% $0
+#% $0 File.expand_path($0)
e=Config::CONFIG
- SiSU_lib="sisu/#{SiSU_version_dir}"
- sisu_path_specified_lib_=if $0 =~ /^#{e['bindir']}\/sisu[34]?$/
+ SiSU_path_base=if $0 =~ /^#{e['bindir']}\/sisu[34]?$/
nil
elsif $0 !~ /^#{e['bindir']}\/sisu[34]?$/ \
- && $0 =~/bin\/sisu[34]?$/ \
- && FileTest.file?($0)
- $0.sub(/bin\/sisu[34]?$/,'lib').
- sub(/^lib$/,"#{Dir.pwd}/lib")
- elsif $0 !~ /^#{e['bindir']}\/sisu[34]?$/ \
- && $0 =~/^sisu[34]?$/ \
+ && File.expand_path($0) =~/bin\/sisu[34]?$/ \
&& FileTest.file?($0)
- $0.sub(/sisu[34]?$/,'../lib')
- #bug, relative path does not work for sisu version information
- else
- nil
- end
- SiSU_path_specified_Version_=if sisu_path_specified_lib_
- sisu_path_specified_lib_.sub(/\/lib/,
- "/data/sisu/#{SiSU_version_dir}/v/version.yml")
+ File.expand_path($0).sub(/\/bin\/sisu[34]?$/,'')
else
nil
end
+ SiSU_lib="sisu/#{SiSU_version_dir}"
+ sisu_path_specified_lib_=SiSU_path_base \
+ ? File.expand_path($0).sub(/bin\/sisu[34]?$/,'lib')
+ : nil
+ SiSU_path_specified_Version_=SiSU_path_base \
+ ? "#{SiSU_path_base}/data/sisu/#{SiSU_version_dir}/v/version.yml"
+ : nil
SiSU_path_lib="#{require_hub_path(sisu_path_specified_lib_)}"
#% $*
require "#{SiSU_path_lib}/hub"
diff --git a/data/doc/sisu/CHANGELOG_v4 b/data/doc/sisu/CHANGELOG_v4
index 0f0ea8e2..15cbe459 100644
--- a/data/doc/sisu/CHANGELOG_v4
+++ b/data/doc/sisu/CHANGELOG_v4
@@ -21,6 +21,24 @@ v2 branch is removed; it is available in sisu =< 3.3.2
%% Reverse Chronological:
+%% 4.0.11.orig.tar.xz (2013-03-06:09/3)
+http://sources.sisudoc.org/gitweb/?p=code/sisu.git;a=shortlog;h=refs/tags/sisu_4.0.11
+http://sources.sisudoc.org/gitweb/?p=code/sisu.git;a=shortlog;h=refs/tags/debian/sisu_4.0.11-1
+http://www.jus.uio.no/sisu/pkg/src/sisu_4.0.11.orig.tar.xz
+ sisu_4.0.11.orig.tar.xz
+ sisu_4.0.11-1.dsc
+
+* v4: bin/sisu, expand given path for sisu executable
+ (where system sisu not called directly)
+
+* v4: sysenv, base images path determined from given path for sisu executable
+ (where system sisu not called directly)
+
+* v4: options, sisupod, name determination, fix
+ * needed for creation of multiple sisupods
+
+* v4: html_format, html segment navigation to toc, fix
+
%% 4.0.10.orig.tar.xz (2013-03-05:09/2)
http://sources.sisudoc.org/gitweb/?p=code/sisu.git;a=shortlog;h=refs/tags/sisu_4.0.10
http://sources.sisudoc.org/gitweb/?p=code/sisu.git;a=shortlog;h=refs/tags/debian/sisu_4.0.10-1
diff --git a/data/sisu/v4/conf/editor-syntax-etc/emacs/sisu-mode.el b/data/sisu/v4/conf/editor-syntax-etc/emacs/sisu-mode.el
index fc0589d8..e738d4b2 100644
--- a/data/sisu/v4/conf/editor-syntax-etc/emacs/sisu-mode.el
+++ b/data/sisu/v4/conf/editor-syntax-etc/emacs/sisu-mode.el
@@ -4,7 +4,7 @@
;; @Version: 4.0.8 2013-02-17 (3.0.7 2011-04-20) (2008-12-14)
;; [3.0.7 2011-04-20 Ambrose Kofi Laing & Ralph Amissah]
;; [4.0.9 2013-02-22 Ralph Amissah]
-;; @URL: <http://git.sisudoc.org/?p=code/sisu.git;a=blob;f=data/sisu/v3/conf/editor-syntax-etc/emacs/sisu-mode.el;hb=HEAD>
+;; @URL: <http://git.sisudoc.org/?p=code/sisu.git;a=blob;f=data/sisu/v4/conf/editor-syntax-etc/emacs/sisu-mode.el;hb=HEAD>
;; @Copyright: Assigned to FSF 2011-04-08 (GNU EMACS)
;; @License: GPLv3
;; @Home URL: SiSU: http://www.jus.uio.no/sisu
diff --git a/data/sisu/v4/v/version.yml b/data/sisu/v4/v/version.yml
index 5776f049..c19a30f5 100644
--- a/data/sisu/v4/v/version.yml
+++ b/data/sisu/v4/v/version.yml
@@ -1,5 +1,5 @@
---
-:version: 4.0.10
-:date_stamp: 2013w09/2
-:date: "2013-03-05"
+:version: 4.0.11
+:date_stamp: 2013w09/3
+:date: "2013-03-06"
:project: SiSU
diff --git a/lib/sisu/v4/html_format.rb b/lib/sisu/v4/html_format.rb
index f96db380..d2c12154 100644
--- a/lib/sisu/v4/html_format.rb
+++ b/lib/sisu/v4/html_format.rb
@@ -106,7 +106,7 @@ module SiSU_HTML_Format
@stylesheet=SiSU_Style::CSS_HeadInfo.new(md).stylesheet
@o_str ||=SiSU_Env::ProcessingSettings.new(md).output_dir_structure
@index,@metalink='index','#metadata'
- @toc="#{@md.file.output_path.html_seg.dir}/#{@md.file.base_filename.html_segtoc}"
+ @toc=@md.file.base_filename.html_segtoc
end
def url_path_image_sys
(@o_str.dump_or_redirect?) \
diff --git a/lib/sisu/v4/options.rb b/lib/sisu/v4/options.rb
index 6e5f7ca4..724fd9a9 100644
--- a/lib/sisu/v4/options.rb
+++ b/lib/sisu/v4/options.rb
@@ -504,7 +504,7 @@ module SiSU_Commandline
case m
when /^--(?:color-toggle)$/; c=c+'c'
when /^--(?:color-off)$/; c=c+'k'
- when /^--(?:configure|init-site)$/; c=c+'CC'
+ when /^--(?:conf|config|configure|init|initialize|init-site)$/; c=c+'CC'
when /^--(?:dal?|machine|abstraction|abs)$/; c=c+'m'
when /^--(?:txt|text|plaintext)$/; c=c+'t'
when /^--(?:html)$/; c=c+'h'
@@ -606,7 +606,7 @@ module SiSU_Commandline
? { bool: true, set: :on }
: { bool: false, set: :na }
act[:site_init]=(cmd =~/C/ \
- || mod.inspect =~/"--init-site"|"--configure"/) \
+ || mod.inspect =~/"--init"|"--initialize"|"--init-site"|"--conf"|"--config"|"--configure"/) \
? { bool: true, set: :on }
: { bool: false, set: :na }
act[:rc]=if mod.inspect =~/"--rc=/
@@ -1012,7 +1012,6 @@ module SiSU_Commandline
def files_mod
files_mod=files
@files_mod=files_mod
- @files_mod
end
def f_pth
@f_pth
@@ -1030,20 +1029,10 @@ module SiSU_Commandline
@lng_base
end
def fno
- @fno=if @fno \
- and not @fno.empty?
- @fno
- else
- fns[/(.+?(?:sst|ssm))(?:\.sst)?/,1]
- end
+ @fno=fns[/(.+?(?:sst|ssm))(?:\.sst)?/,1]
end
def fng
- @fng=if @fng \
- and not @fng.empty?
- @fng
- else
- fno.gsub(/(?:~(?:#{Px[:lng_lst_rgx]}))?(\.ss[tm])$/,'\1')
- end
+ @fng=fno.gsub(/(?:~(?:#{Px[:lng_lst_rgx]}))?(\.ss[tm])$/,'\1')
end
def fns
@fns
diff --git a/lib/sisu/v4/shared_sisupod_source.rb b/lib/sisu/v4/shared_sisupod_source.rb
index 192648cf..0ec739bb 100644
--- a/lib/sisu/v4/shared_sisupod_source.rb
+++ b/lib/sisu/v4/shared_sisupod_source.rb
@@ -68,13 +68,13 @@ module SiSU_Source
@opt=opt
m=/.+\/(?:src\/)?(\S+)/im
@date=SiSU_Env::InfoDate.new.dt
- @env=SiSU_Env::InfoEnv.new(@opt.fns)
+ @env=SiSU_Env::InfoEnv.new(opt.fns)
@ver=SiSU_Env::InfoVersion.instance.get_version
- @v=(@opt.cmd =~/[VM]/) ? 'v' : ''
+ @v=(opt.cmd =~/[VM]/) ? 'v' : ''
@particulars=SiSU_Particulars::CombinedSingleton.instance.get_all(opt)
@file=@particulars.file
@local_path="#{@file.output_path.sisupod.dir}"
- processing_sisupod=@env.processing_path.processing_sisupod(@opt)
+ processing_sisupod=@env.processing_path.processing_sisupod(opt)
processing_sisupod.make
path_pod=processing_sisupod.paths[:sisupod]
path_pod_fnb=processing_sisupod.paths[:fnb]
@@ -82,8 +82,8 @@ module SiSU_Source
@path_pod={
fnb: path_pod_fnb,
pod: path_pod,
- doc: path_pod + '/' + Gt[:doc] + '/' + @opt.lng,
- po: path_pod + '/' + Gt[:po] + '/' + @opt.lng,
+ doc: path_pod + '/' + Gt[:doc] + '/' + opt.lng,
+ po: path_pod + '/' + Gt[:po] + '/' + opt.lng,
pot: path_pod + '/' + Gt[:pot],
conf: path_pod + '/' + Gt[:conf],
image: path_pod + '/' + Gt[:image],
diff --git a/lib/sisu/v4/sysenv.rb b/lib/sisu/v4/sysenv.rb
index c3f69c85..f3191be1 100644
--- a/lib/sisu/v4/sysenv.rb
+++ b/lib/sisu/v4/sysenv.rb
@@ -2145,7 +2145,6 @@ WOK
else
sisupod_processing_path + '/' + Gt[:doc]
end
-#p sisup od_processing_path_lng
unless FileTest.directory?(sisupod_processing_path_lng)
#puts "a processing directory (#{sisupod_processing_path_lng}) is being created for use by sisu"
FileUtils::mkdir_p(sisupod_processing_path_lng)
@@ -5956,7 +5955,9 @@ WOK
cp_images(src,dest) if FileTest.directory?(src)
end
def cp_base_images #fix images
- src="#{@env.path.share}/image"
+ src=SiSU_path_base \
+ ? SiSU_path_base + '/data/sisu/image'
+ : "#{@env.path.share}/image"
dest_arr=[
"#{@env.path.webserv}/_sisu/image_sys",
"#{@env.path.webserv}/#{@env.path.stub_pwd}/_sisu/image_sys"