aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-03-05 21:47:08 -0500
committerRalph Amissah <ralph@amissah.com>2013-03-05 21:47:08 -0500
commit98b3549d115436c0419d29cf7d7f5521a3640e7b (patch)
treecaf01b400b81813983283778e03060c86e529136
parentdebian/changelog (4.0.9-1) (diff)
parentv4: html, epub, minor "cleaning" of output (diff)
Merge tag 'sisu_4.0.10' into debian/sid
SiSU 4.0.10
-rw-r--r--data/doc/sisu/CHANGELOG_v416
-rw-r--r--data/sisu/v4/v/version.yml6
-rw-r--r--lib/sisu/v4/epub_format.rb15
-rw-r--r--lib/sisu/v4/html_format.rb30
-rw-r--r--lib/sisu/v4/html_scroll.rb2
-rw-r--r--lib/sisu/v4/html_segments.rb2
-rw-r--r--lib/sisu/v4/sysenv.rb12
-rw-r--r--lib/sisu/v4/texpdf.rb9
-rw-r--r--lib/sisu/v4/texpdf_format.rb1
9 files changed, 56 insertions, 37 deletions
diff --git a/data/doc/sisu/CHANGELOG_v4 b/data/doc/sisu/CHANGELOG_v4
index b8d88e1b..0f0ea8e2 100644
--- a/data/doc/sisu/CHANGELOG_v4
+++ b/data/doc/sisu/CHANGELOG_v4
@@ -21,6 +21,22 @@ v2 branch is removed; it is available in sisu =< 3.3.2
%% Reverse Chronological:
+%% 4.0.10.orig.tar.xz (2013-03-05:09/2)
+http://sources.sisudoc.org/gitweb/?p=code/sisu.git;a=shortlog;h=refs/tags/sisu_4.0.10
+http://sources.sisudoc.org/gitweb/?p=code/sisu.git;a=shortlog;h=refs/tags/debian/sisu_4.0.10-1
+http://www.jus.uio.no/sisu/pkg/src/sisu_4.0.10.orig.tar.xz
+ sisu_4.0.10.orig.tar.xz
+ sisu_4.0.10-1.dsc
+
+* v4: texpdf, report to STDERR when pdf not (successfully) generated, note:
+ .tex file is almost certainly produced by sisu, this will be a sisu packaging,
+ texlive dependency issue, preventing its conversion to pdf (Closes: #617359)
+
+* v4: sysenv, set default output (directory layout) type where none configured
+ (also turned off reporting where imagemagick & graphicsmagick not installed)
+
+* v4: html, epub, minor "cleaning" of output
+
%% 4.0.9.orig.tar.xz (2013-02-22:07/5)
http://sources.sisudoc.org/gitweb/?p=code/sisu.git;a=shortlog;h=refs/tags/sisu_4.0.9
http://sources.sisudoc.org/gitweb/?p=code/sisu.git;a=shortlog;h=refs/tags/debian/sisu_4.0.9-1
diff --git a/data/sisu/v4/v/version.yml b/data/sisu/v4/v/version.yml
index 447a2e9e..5776f049 100644
--- a/data/sisu/v4/v/version.yml
+++ b/data/sisu/v4/v/version.yml
@@ -1,5 +1,5 @@
---
-:version: 4.0.9
-:date_stamp: 2013w07/5
-:date: "2013-02-22"
+:version: 4.0.10
+:date_stamp: 2013w09/2
+:date: "2013-03-05"
:project: SiSU
diff --git a/lib/sisu/v4/epub_format.rb b/lib/sisu/v4/epub_format.rb
index 49139667..683228c3 100644
--- a/lib/sisu/v4/epub_format.rb
+++ b/lib/sisu/v4/epub_format.rb
@@ -70,25 +70,26 @@ module SiSU_EPUB_Format
make=SiSU_Env::ProcessingSettings.new(@md)
if make.build.ocn?
ocn_class='ocn'
- if @ocn.to_i==0
- @ocn.gsub(/^(\d+|)$/,'')
+ if @ocn==nil \
+ or @ocn.to_i==0 \
+ or @ocn.empty?
+ %{<label class="ocn_off"></label>}
else
@ocn.gsub(/^(\d+|)$/,
%{<label class="#{ocn_class}"><a href="#o\\1" class="lnk#{ocn_class}">\\1</a></label>})
end
else
- ocn_class='ocn_off'
- @ocn.gsub(/^(\d+|)$/,'')
+ %{<label class="ocn_off"></label>}
end
end
def name
- %{<a name="#{@ocn}"></a>}
+ (@ocn==nil || @ocn.empty?) ? '' : %{<a name="#{@ocn}"></a>}
end
def id #w3c? "tidy" complains about numbers as identifiers ! annoying
- (@ocn.empty?) ? '' : %{id="o#{@ocn}"}
+ (@ocn==nil || @ocn.empty?) ? '' : %{id="o#{@ocn}"}
end
def goto
- %{<a href="##{@ocn}">}
+ (@ocn==nil || @ocn.empty?) ? '' : %{<a href="##{@ocn}">}
end
end
class CSS
diff --git a/lib/sisu/v4/html_format.rb b/lib/sisu/v4/html_format.rb
index 25a8dbee..f96db380 100644
--- a/lib/sisu/v4/html_format.rb
+++ b/lib/sisu/v4/html_format.rb
@@ -70,27 +70,25 @@ module SiSU_HTML_Format
make=SiSU_Env::ProcessingSettings.new(@md)
if make.build.ocn?
ocn_class='ocn'
- if @ocn.to_i==0
- @ocn.gsub(/^(\d+|)$/,
- %{<label class="#{ocn_class}"><a name="#{@ocn}">&nbsp;</a></label>})
+ if @ocn.to_i==0 \
+ or @ocn.empty?
+ %{<label class="ocn_off">&nbsp;</label>}
else
@ocn.gsub(/^(\d+|)$/,
%{<label class="#{ocn_class}"><a name="#{@ocn}" href="##{@ocn}" class="lnk#{ocn_class}">\\1</a></label>})
end
else
- ocn_class='ocn_off'
- @ocn.gsub(/^(\d+|)$/,
- %{<label class="#{ocn_class}">&nbsp;</label>})
+ %{<label class="ocn_off">&nbsp;</label>}
end
end
def name
- %{<a name="#{@ocn}"></a>}
+ (@ocn==nil || @ocn.empty?) ? '' : %{<a name="#{@ocn}"></a>}
end
def id #w3c? "tidy" complains about numbers as identifiers ! annoying
- %{id="o#{@ocn}"}
+ (@ocn==nil || @ocn.empty?) ? '' : %{id="o#{@ocn}"}
end
def goto
- %{<a href="##{@ocn}">}
+ (@ocn==nil || @ocn.empty?) ? '' : %{<a href="##{@ocn}">}
end
end
class HeadInformation
@@ -517,15 +515,13 @@ WOK
%{<p class="small_left">Prefix: #{@md.prefix_b}<p />}
end
def scroll_head_title_banner_open
- %{<center>
-#{@md.icon}
-</center>
+ icon=@md.icon ? %{<center>\n#{@md.icon}\n</center>} : ''
+ %{#{icon}
#{@vz.banner_instrument_cover_band_scr}}
end
def seg_head_title_banner_open
- %{<center>
- #{@md.icon}
-</center>
+ icon=@md.icon ? %{<center>\n#{@md.icon}\n</center>} : ''
+ %{#{icon}
#{@vz.banner_instrument_cover_band_seg}}
end
def make_scroll
@@ -619,8 +615,6 @@ WOK
<a name="stop" id="stop"></a>
<a name="credits"></a>
</div>
-</div>
-</div>
}
end
def seg_navigation_tail #this is a bug area, look up and "tidy"
@@ -1029,7 +1023,7 @@ WOK
end
def heading_normal(tag,attrib)
section_break=(tag=~/h[1-4]/) \
- ? '<p><hr width=90% /></p>'
+ ? '<br /><hr width=90% /><br />'
: ''
%{#{section_break}
<div class="substance">
diff --git a/lib/sisu/v4/html_scroll.rb b/lib/sisu/v4/html_scroll.rb
index 84ec0515..f3711460 100644
--- a/lib/sisu/v4/html_scroll.rb
+++ b/lib/sisu/v4/html_scroll.rb
@@ -129,7 +129,7 @@ module SiSU_HTML_Scroll
end
elsif dob.is==:break \
and dob.from==:markup
- '<p><hr width=90% /></p>'
+ '<br /><hr width=90% /><br />'
elsif dob.is==:heading_insert
x=if dob.ln==1
unless dob.obj.empty?
diff --git a/lib/sisu/v4/html_segments.rb b/lib/sisu/v4/html_segments.rb
index 21fdc7cc..55335845 100644
--- a/lib/sisu/v4/html_segments.rb
+++ b/lib/sisu/v4/html_segments.rb
@@ -480,7 +480,7 @@ module SiSU_HTML_Seg
sto.table
elsif dob.is==:break \
and dob.from==:markup
- '<p><hr width=90% /></p>'
+ '<br /><hr width=90% /><br />'
end
if @md.flag_separate_endnotes
dob.obj=dob.obj.gsub(/"\s+href="#_(\d+)">/,%{" href=\"endnotes#{Sfx[:html]}#_\\1">}) #endnote- twice #removed file type
diff --git a/lib/sisu/v4/sysenv.rb b/lib/sisu/v4/sysenv.rb
index 17acc872..c3f69c85 100644
--- a/lib/sisu/v4/sysenv.rb
+++ b/lib/sisu/v4/sysenv.rb
@@ -470,9 +470,11 @@ module SiSU_Env
or ((defined? @rc['output_structure']['by_filename']) \
&& @rc['output_structure']['by_filename'] ==true)
:filename
- else #recheck current default
+ else #set default
:language
end
+ else #set default
+ :language
end
end
def dump?
@@ -789,14 +791,14 @@ module SiSU_Env
program='identify'
program_ref="\n\t\tsee <http://www.imagemagick.org/>"
found=(program_found?(program)) ? true : false
- STDERR.puts "\t*WARN* #{program} is not installed #{program_ref}" unless found
+ #STDERR.puts "\t*WARN* #{program} is not installed #{program_ref}" unless found
found
end
def graphicksmagick #graphicsmagick is a image manipulation program
program='gm'
program_ref="\n\t\tsee <http://www.graphicsmagick.org/>"
found=(program_found?(program)) ? true : false
- STDERR.puts "\t*WARN* #{program} is not installed #{program_ref}" unless found
+ #STDERR.puts "\t*WARN* #{program} is not installed #{program_ref}" unless found
found
end
def well_formed? #tidy - check for well formed xml xhtml etc.
@@ -3487,6 +3489,7 @@ WOK
class InfoVersion <InfoEnv
include Singleton
require 'rbconfig'
+ require 'yaml'
@@lib_path=nil
def get_version
@version={}
@@ -3496,7 +3499,8 @@ WOK
: "#{defaults[:sisu_share]}/#{SiSU_version_dir}/v/version.yml"
lib_path=@@lib_path ? @@lib_path : `echo $RUBYLIB`.split(':')
@@lib_path ||=lib_path
- if File.exist?(yst_ver); @version=YAML::load(File::open(yst_ver)) #unless @@noyaml
+ if File.exist?(yst_ver)
+ @version=YAML::load(File::open(yst_ver)) #unless @@noyaml
end
@version
end
diff --git a/lib/sisu/v4/texpdf.rb b/lib/sisu/v4/texpdf.rb
index 5e18f5aa..4ad385d6 100644
--- a/lib/sisu/v4/texpdf.rb
+++ b/lib/sisu/v4/texpdf.rb
@@ -203,18 +203,23 @@ module SiSU_TeX
else pdf_p=@f.pdf_p_a4; pdf_l=@f.pdf_l_a4
end
FileUtils::mkdir_p(@md.file.output_path.pdf.dir) unless FileTest.directory?(@md.file.output_path.pdf.dir)
+ cX=SiSU_Screen::Ansi.new(@md.opt.cmd).cX
if @md.opt.act[:pdf_p][:set]==:on
if FileTest.file?(portrait_pdf)
FileUtils::cp(portrait_pdf,"#{@md.file.output_path.pdf.dir}/#{pdf_p}")
FileUtils::rm(portrait_pdf)
- else p "#{__FILE__}:#{__LINE__} NOT FOUND: #{portrait_pdf}" if @md.opt.cmd.inspect =~/M/
+ else
+ STDERR.puts "#{cX.fuschia}pdf file not generated#{cX.off} <#{cX.blue}#{portrait_pdf.gsub(/.+?([^\/]+?\.pdf)$/,'\1')}#{cX.off}> (check texlive dependencies)"
+ STDERR.puts "#{__FILE__}:#{__LINE__} NOT FOUND: #{portrait_pdf}" if @md.opt.cmd.inspect =~/M/
end
end
if @md.opt.act[:pdf_l][:set]==:on
if FileTest.file?(landscape_pdf)
FileUtils::cp(landscape_pdf,"#{@md.file.output_path.pdf.dir}/#{pdf_l}")
FileUtils::rm(landscape_pdf)
- else p "#{__FILE__}:#{__LINE__} NOT FOUND: #{landscape_pdf}" if @md.opt.cmd.inspect =~/M/
+ else
+ STDERR.puts "#{cX.fuschia}pdf file not generated#{cX.off} <#{cX.blue}#{landscape_pdf.gsub(/.+?([^\/]+?\.pdf)$/,'\1')}#{cX.off}> (check texlive dependencies)"
+ STDERR.puts "#{__FILE__}:#{__LINE__} NOT FOUND: #{landscape_pdf}" if @md.opt.cmd.inspect =~/M/
end
end
SiSU_Screen::Ansi.new(@md.opt.cmd,@@n_lpdf,'processed (SiSU LaTeX to pdf - using pdfetex aka. pdftex or pdflatex)').generic_number if @md.opt.cmd =~/[MVv]/
diff --git a/lib/sisu/v4/texpdf_format.rb b/lib/sisu/v4/texpdf_format.rb
index 0027fb0d..9a1429de 100644
--- a/lib/sisu/v4/texpdf_format.rb
+++ b/lib/sisu/v4/texpdf_format.rb
@@ -1195,7 +1195,6 @@ module SiSU_TeX_Pdf
gsub(/\\copy(right|mark)?/,'<=copymark>') # ok problem with superscript
end
def xetex_special_characters_1(str,is=:default) # ~ ^ $ & % _ { } #LaTeX special characters - KEEP list
- #str=Iconv.conv('ISO-8859-1', 'UTF-8', @txt) # `require': iconv will be deprecated in the future, use String#encode instead.
word=str.scan(/\S+|\n/) #unless line =~/^(?:@\S|%+\s)/
para_array=[]
str=if word