aboutsummaryrefslogtreecommitdiffhomepage
path: root/bin
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2011-03-02 22:54:28 -0500
committerRalph Amissah <ralph@amissah.com>2011-03-02 22:54:28 -0500
commit0569fd776ab4ce33689ca3337acd62f2415b6348 (patch)
tree4644037b28d876d8637a610f5df1a29535a4ef9a /bin
parentdebian/changelog (3.0.1-1) (diff)
parentCHANGELOG_v{1,2,3}, syslink, avoid duplication (diff)
Merge branch 'upstream' into debian/sid
Diffstat (limited to 'bin')
-rw-r--r--bin/sisu18
-rw-r--r--bin/sisu319
-rw-r--r--bin/sisu_termsheet2
-rw-r--r--bin/sisu_webrick2
4 files changed, 35 insertions, 6 deletions
diff --git a/bin/sisu b/bin/sisu
index dd1db245..5da17513 100644
--- a/bin/sisu
+++ b/bin/sisu
@@ -1,8 +1,20 @@
#!/usr/bin/env ruby
-# coding: utf-8
+# encoding: utf-8
#SiSU: copyright (C) 1997 - 2011 Ralph Amissah; License GPL, see appended program information
#raise "Please, use Ruby1.8 (1.8.4 or later), current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4' or RUBY_VERSION > '1.9'
-raise "Please, use Ruby1.8.4 or later, current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4'
+def check_sisu_stable_ruby_version?
+ rbv_sisu_stable='1.8.7'
+ if RUBY_VERSION < rbv_sisu_stable
+ raise "Please, use Ruby#{rbv_sisu_stable} or later, current Ruby #{RUBY_VERSION}"
+ end
+end
+def check_sisu_dev_ruby_version?
+ rbv_sisu_dev='1.9.2'
+ if RUBY_VERSION < rbv_sisu_dev
+ raise "Please, use Ruby#{rbv_sisu_dev} or later, current Ruby #{RUBY_VERSION}"
+ end
+end
+check_sisu_stable_ruby_version?
$VERBOSE=nil
$KCODE='u' if RUBY_VERSION < '1.9'
argv=$*
@@ -10,8 +22,10 @@ SiSU_version_dir=case argv.inspect
when /--v2/
'v2'
when /--v3/
+ check_sisu_dev_ruby_version?
'v3'
when /--dev/
+ check_sisu_dev_ruby_version?
'v3'
else
'v2'
diff --git a/bin/sisu3 b/bin/sisu3
index ca5be5e7..359a8744 100644
--- a/bin/sisu3
+++ b/bin/sisu3
@@ -1,8 +1,20 @@
#!/usr/bin/env ruby
-# coding: utf-8
+# encoding: utf-8
#SiSU: copyright (C) 1997 - 2011 Ralph Amissah; License GPL, see appended program information
#raise "Please, use Ruby1.8 (1.8.4 or later), current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4' or RUBY_VERSION > '1.9'
-raise "Please, use Ruby1.8.4 or later, current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4'
+def check_sisu_stable_ruby_version?
+ rbv_sisu_stable='1.8.7'
+ if RUBY_VERSION < rbv_sisu_stable
+ raise "Please, use Ruby#{rbv_sisu_stable} or later, current Ruby #{RUBY_VERSION}"
+ end
+end
+def check_sisu_dev_ruby_version?
+ rbv_sisu_dev='1.9.2'
+ if RUBY_VERSION < rbv_sisu_dev
+ raise "Please, use Ruby#{rbv_sisu_dev} or later, current Ruby #{RUBY_VERSION}"
+ end
+end
+check_sisu_stable_ruby_version?
$VERBOSE=nil
$KCODE='u' if RUBY_VERSION < '1.9'
argv=$*
@@ -10,10 +22,13 @@ SiSU_version_dir=case argv.inspect
when /--v2/
'v2'
when /--v3/
+ check_sisu_dev_ruby_version?
'v3'
when /--dev/
+ check_sisu_dev_ruby_version?
'v3'
else
+ check_sisu_dev_ruby_version?
'v3'
end
SiSU_lib="sisu/#{SiSU_version_dir}"
diff --git a/bin/sisu_termsheet b/bin/sisu_termsheet
index 5a9da294..47af2dcc 100644
--- a/bin/sisu_termsheet
+++ b/bin/sisu_termsheet
@@ -1,5 +1,5 @@
#!/usr/bin/env ruby
-# coding: utf-8
+# encoding: utf-8
#SiSU: copyright (C) 1997 - 2011 Ralph Amissah; License GPL, see appended program information
raise "Please, use Ruby1.8 (1.8.4 or later), current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4' or RUBY_VERSION > '1.9'
#raise "Please, use Ruby1.8.4 or later, current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4'
diff --git a/bin/sisu_webrick b/bin/sisu_webrick
index 42419e36..1b2a724c 100644
--- a/bin/sisu_webrick
+++ b/bin/sisu_webrick
@@ -1,5 +1,5 @@
#!/usr/bin/env ruby
-# coding: utf-8
+# encoding: utf-8
#SiSU: copyright (C) 1997 - 2011 Ralph Amissah; License GPL, see appended program information
raise "Please, use Ruby1.8 (1.8.4 or later), current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4' or RUBY_VERSION > '1.9'
#raise "Please, use Ruby1.8.4 or later, current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4'