aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v0/db_create.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2008-05-10 12:15:04 -0400
committerRalph Amissah <ralph@amissah.com>2008-05-10 12:15:04 -0400
commit61a533c385db51965fb85148a5791ded161ec639 (patch)
tree4e64a0d1cf78ed5cfca03687219350695c0f1226 /lib/sisu/v0/db_create.rb
parentuse debhelper 7, add vcs info to debian/control (diff)
parentupdate changelog (diff)
Merge branch 'upstream' into debian/sid
Diffstat (limited to 'lib/sisu/v0/db_create.rb')
-rw-r--r--lib/sisu/v0/db_create.rb8
1 files changed, 5 insertions, 3 deletions
diff --git a/lib/sisu/v0/db_create.rb b/lib/sisu/v0/db_create.rb
index bf622bef..95803324 100644
--- a/lib/sisu/v0/db_create.rb
+++ b/lib/sisu/v0/db_create.rb
@@ -64,8 +64,8 @@ module SiSU_DB_create
class Create < SiSU_DB_columns::Column_size
require "#{SiSU_lib}/sysenv"
@@dl=nil
- def initialize(opt,conn='',sql_type='pg')
- @opt,@conn,@sql_type=opt,conn,sql_type
+ def initialize(opt,conn,file,sql_type='pg')
+ @opt,@conn,@file,@sql_type=opt,conn,file,sql_type
@cX=SiSU_Screen::Ansi.new(@opt.cmd).cX
@comment=Comment.new(@sql_type)
@@dl ||=SiSU_Env::Info_env.new.digest.length
@@ -86,7 +86,9 @@ module SiSU_DB_create
end
def output_dir?
dir=SiSU_Env::Info_env.new('')
- if @opt.cmd =~/d/; dir.path.webserv_stub_ensure
+ if @opt.cmd =~/d/
+ #p dir.path.webserv_stub_ensure.inspect
+ dir.path.webserv_stub_ensure
end
end
def create_table