aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v0/db_tests.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2008-05-10 12:15:04 -0400
committerRalph Amissah <ralph@amissah.com>2008-05-10 12:15:04 -0400
commit61a533c385db51965fb85148a5791ded161ec639 (patch)
tree4e64a0d1cf78ed5cfca03687219350695c0f1226 /lib/sisu/v0/db_tests.rb
parentuse debhelper 7, add vcs info to debian/control (diff)
parentupdate changelog (diff)
Merge branch 'upstream' into debian/sid
Diffstat (limited to 'lib/sisu/v0/db_tests.rb')
-rw-r--r--lib/sisu/v0/db_tests.rb8
1 files changed, 4 insertions, 4 deletions
diff --git a/lib/sisu/v0/db_tests.rb b/lib/sisu/v0/db_tests.rb
index 73e0400f..72282b59 100644
--- a/lib/sisu/v0/db_tests.rb
+++ b/lib/sisu/v0/db_tests.rb
@@ -64,9 +64,9 @@ module SiSU_DB_tests
def initialize(info,opt)
@ck,@opt=info,opt
unless @opt.cmd =~/q/
- puts @ck.tp[:fns]
- puts @ck.tp[:title]
- puts @ck.tp[:creator] if @ck.tp[:creator]
+ puts @ck.tp[:fns] if @ck.tp[:fns] and not @ck.tp[:fns].empty?
+ puts @ck.tp[:title] if @ck.tp[:title] and not @ck.tp[:title].empty?
+ puts @ck.tp[:creator] if @ck.tp[:creator] and not @ck.tp[:creator].empty?
end
end
def verify
@@ -109,7 +109,7 @@ module SiSU_DB_tests
puts @ck.tp[:dewey].length.to_s + ' checklength ' + @ck.tp[:dewey] if @ck.tp[:dewey] and @ck.tp[:dewey].length >@ck.lt_dewey
puts @ck.tp[:isbn].length.to_s + ' checklength ' + @ck.tp[:isbn] if @ck.tp[:isbn] and @ck.tp[:isbn].length >@ck.lt_isbn
puts @ck.tp[:pg].length.to_s + ' checklength ' + @ck.tp[:pg] if @ck.tp[:pg] and @ck.tp[:pg].length >@ck.lt_pg
- puts @ck.tp[:date] if @ck.tp[:date] !~/\d\d-\d\d-\d\d/
+ puts @ck.tp[:date] if @ck.tp[:date] and not @ck.tp[:date].empty? and @ck.tp[:date] !~/\d\d-\d\d-\d\d/
end
end
end