aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v2/sisupod_make.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2010-04-27 19:43:49 -0400
committerRalph Amissah <ralph@amissah.com>2010-04-27 19:43:49 -0400
commit32fac381f59adf99295fdd73f96b22737d714a0b (patch)
tree671e38fe7805160a24a3a0b317cdcaecf7483b6a /lib/sisu/v2/sisupod_make.rb
parentdebian/changelog (2.2.0-1), debian/NEWS.Debian (diff)
parentupdate: changelog, version (2.3.0) (diff)
Merge branch 'upstream' into debian/sid
Diffstat (limited to 'lib/sisu/v2/sisupod_make.rb')
-rw-r--r--lib/sisu/v2/sisupod_make.rb8
1 files changed, 4 insertions, 4 deletions
diff --git a/lib/sisu/v2/sisupod_make.rb b/lib/sisu/v2/sisupod_make.rb
index 50d55a38..0b4b56d8 100644
--- a/lib/sisu/v2/sisupod_make.rb
+++ b/lib/sisu/v2/sisupod_make.rb
@@ -161,11 +161,11 @@ module SiSU_Doc
def sisupod_build #see also sisupod in sysenv
@rgx_rb_image=/["'](\S+?\.(?:png|jpg|gif))["']/
@rgx_image=/(?:^|[^_\\])\{\s*(\S+?\.(?:png|jpg|gif))/
- @rgx_skin=/^@skin:\s+(\S+)/
+ @rgx_skin=/^\s+:skin:\s+(\S+)/
@rgx_doc_import=/^%\s\s*\|(\S+?\.ss[ti])\|@\|\^\|>>ok/
- use_file=if @opt.fns =~/(?:\.ssm|\.ssm\.sst)$/; "#{@env.path.composite_file}/#{@opt.fnb}.ssm.sst"
- else @opt.fns
- end
+ use_file=@opt.fns =~/(?:\.ssm|\.ssm\.sst)$/ \
+ ? "#{@env.path.composite_file}/#{@opt.fnb}.ssm.sst" \
+ : @opt.fns
file_array=IO.readlines(use_file,'')
skin,images,doc_import=[],[],[]
file_array.each do |f| #% work area