aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/db_select.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2011-05-05 22:11:58 -0400
committerRalph Amissah <ralph@amissah.com>2011-05-05 22:11:58 -0400
commita9642d67f69d83d3fdb56ab115ef3c10bcd1895c (patch)
tree352c633d6b60a54a9ef74ff143162ac07c981b18 /lib/sisu/v3/db_select.rb
parentdebian/changelog (3.0.7-1) (diff)
parentv3: i18n, sysenv, class variable to prevent unnecessary re-construction of hash (diff)
Merge branch 'upstream' into debian/sid
Diffstat (limited to 'lib/sisu/v3/db_select.rb')
-rw-r--r--lib/sisu/v3/db_select.rb10
1 files changed, 8 insertions, 2 deletions
diff --git a/lib/sisu/v3/db_select.rb b/lib/sisu/v3/db_select.rb
index 9bf8acbc..0cd34bcd 100644
--- a/lib/sisu/v3/db_select.rb
+++ b/lib/sisu/v3/db_select.rb
@@ -164,7 +164,7 @@ module SiSU_DB_select
db_exist?
@sdb_import.marshal_load
tell=case @sql_type
- when /sqlite/; SiSU_Screen::Ansi.new(@opt.cmd,"sqlite #{@db.sqlite.db} database?")
+ when /sqlite/; SiSU_Screen::Ansi.new(@opt.cmd,"sqlite3 #{@db.sqlite.db} database?")
when /pg/; SiSU_Screen::Ansi.new(@opt.cmd,"pgaccess or psql #{@db.psql.db} database?")
else '???'
end
@@ -173,7 +173,13 @@ module SiSU_DB_select
db_exist?
@sdb_remove_doc.remove
@sdb_import.marshal_load
- SiSU_Screen::Ansi.new(@opt.cmd,"pgaccess or psql #{@db.psql.db} database?").puts_grey if @opt.cmd =~/v/
+ tell=case @sql_type
+ when /sqlite/; SiSU_Screen::Ansi.new(@opt.cmd,"sqlite3 #{@db.sqlite.db} database?")
+ when /pg/; SiSU_Screen::Ansi.new(@opt.cmd,"pgaccess or psql #{@db.psql.db} database?")
+ else '???'
+ end
+ tell.puts_grey if @opt.cmd =~/v/
+ when /^--update$/
when /^--remove$/
db_exist?
@sdb_remove_doc.remove