aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/epub_format.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-02-20 22:30:24 -0500
committerRalph Amissah <ralph@amissah.com>2013-02-20 22:30:24 -0500
commit1c33d8106063e96da4750098efce9b8d9f87cc02 (patch)
tree76f2006cb0385bef8a796e64b25cfaac3e2d6425 /lib/sisu/v3/epub_format.rb
parentdebian/changelog (4.0.7-1) (diff)
parentv4 (v3): version & changelog, dates touched (diff)
Merge tag 'sisu_4.0.8' into debian/sid
SiSU 4.0.8
Diffstat (limited to 'lib/sisu/v3/epub_format.rb')
-rw-r--r--lib/sisu/v3/epub_format.rb6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/sisu/v3/epub_format.rb b/lib/sisu/v3/epub_format.rb
index 61accf22..228c2df4 100644
--- a/lib/sisu/v3/epub_format.rb
+++ b/lib/sisu/v3/epub_format.rb
@@ -1402,7 +1402,7 @@ output_epub_cont_seg.close
end
def navpoint(dob,no,name=nil)
name=name ? name : dob.name
- cont_name=(name =~/#{Sfx[:epub_xhtml]}/) ? name : (name + Sfx[:epub_xhtml])
+ cont_name=(name =~/#{Sfx[:epub_xhtml]}/) ? name : (name + Sfx[:epub_xhtml])
id_u=DISABLE[:epub][:ncx_navpoint_unique_id] \
? ''
: "-#{no}"
@@ -1597,7 +1597,7 @@ output_epub_cont_seg.close
end
def manifest_content(dob,name=nil)
name=name ? name : dob.name
- href_name=(name =~/#{Sfx[:epub_xhtml]}/) ? name : (name + Sfx[:epub_xhtml])
+ href_name=(name =~/#{Sfx[:epub_xhtml]}/) ? name : (name + Sfx[:epub_xhtml])
<<-WOK
<item id="#{name}" href="#{href_name}" media-type="application/xhtml+xml" />
WOK
@@ -1654,7 +1654,7 @@ output_epub_cont_seg.close
end
def guide(dob,name=nil)
name=name ? name : dob.name
- guide_name=(name =~/#{Sfx[:epub_xhtml]}/) ? name : (name + Sfx[:epub_xhtml])
+ guide_name=(name =~/#{Sfx[:epub_xhtml]}/) ? name : (name + Sfx[:epub_xhtml])
<<-WOK
<reference type="text" href="#{guide_name}" />
WOK