aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/html.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-06-06 23:54:36 -0400
committerRalph Amissah <ralph@amissah.com>2012-06-06 23:54:36 -0400
commite02c0129e10e4ed8e102978df31a7e370f5b868b (patch)
tree475e987720aaccce8f6c0cadb53649a589b893a2 /lib/sisu/v3/html.rb
parentdebian/changelog (3.2.11-1) (diff)
parentv3: hub, post bundles, sisupod_make, file selection selection for tar.xz, fix (diff)
Merge tag 'sisu_3.2.12' into debian/sid
Diffstat (limited to 'lib/sisu/v3/html.rb')
-rw-r--r--lib/sisu/v3/html.rb8
1 files changed, 6 insertions, 2 deletions
diff --git a/lib/sisu/v3/html.rb b/lib/sisu/v3/html.rb
index a5c1edb1..100916ff 100644
--- a/lib/sisu/v3/html.rb
+++ b/lib/sisu/v3/html.rb
@@ -530,7 +530,9 @@ WOK
@segtoc << format_head_toc.head << ads.div.major
toc_shared << format_head_toc.toc_head_escript if SiSU_HTML_Format::HeadToc.method_defined? :toc_head_escript
@segtoc << format_head_toc.toc_head_escript if SiSU_HTML_Format::HeadToc.method_defined? :toc_head_escript
- toc_shared << format_head_toc.scroll_head_navigation_band
+ if @make.build.html_top_band?
+ toc_shared << format_head_toc.scroll_head_navigation_band
+ end
if defined? @md.rights.all
rights=format_head_toc.rights.all
rights=SiSU_HTML_Tune::CleanHTML.new(rights).clean
@@ -539,7 +541,9 @@ WOK
prefix_b=format_head_toc.notes.prefix_b
prefix_b=SiSU_HTML_Tune::CleanHTML.new(prefix_b).clean
end
- @segtoc << format_head_toc.seg_head_navigation_band
+ if @make.build.html_top_band?
+ @segtoc << format_head_toc.seg_head_navigation_band
+ end
toc_shared << format_head_toc.scroll_head_title_banner_open
@segtoc << format_head_toc.seg_head_title_banner_open
tmp_head=nil