aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/html_segments.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2011-07-26 20:40:58 -0400
committerRalph Amissah <ralph@amissah.com>2011-07-26 20:40:58 -0400
commit50f12ee84e59d8f74f443c54ab3b11f50ac79346 (patch)
treec36f14b0044525b5e08924c9e25aa8e9f4392472 /lib/sisu/v3/html_segments.rb
parentdebian/changelog (3.0.13-1) (diff)
parentv2 v3: manpage html (man2html) (diff)
Merge branch 'upstream' into debian/sid
Diffstat (limited to 'lib/sisu/v3/html_segments.rb')
-rw-r--r--lib/sisu/v3/html_segments.rb20
1 files changed, 13 insertions, 7 deletions
diff --git a/lib/sisu/v3/html_segments.rb b/lib/sisu/v3/html_segments.rb
index ccd48407..e6dc0d35 100644
--- a/lib/sisu/v3/html_segments.rb
+++ b/lib/sisu/v3/html_segments.rb
@@ -389,16 +389,22 @@ module SiSU_HTML_seg
end
elsif dob.is=='para'
if dob.indent \
- and dob.indent =~/[1-9]/
+ and dob.hang \
+ and dob.indent =~/[0-9]/ \
+ and dob.hang =~/[0-9]/
if dob.bullet_
- sto.format('li',"i#{dob.indent}")
- else sto.format('p',"i#{dob.indent}")
- end
- else
- if dob.bullet_
- sto.format('li','bullet')
+ if dob.indent =~/[1-9]/
+ sto.format('li',"i#{dob.indent}")
+ else
+ sto.format('li','bullet')
+ end
+ elsif dob.indent == dob.hang
+ sto.format('p',"i#{dob.indent}")
+ elsif dob.indent != dob.hang
+ sto.format('p',"h#{dob.hang}i#{dob.indent}")
else sto.para
end
+ else sto.para
end
end
elsif dob.is=='block'