aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/options.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2011-12-19 22:54:57 -0500
committerRalph Amissah <ralph@amissah.com>2011-12-19 22:54:57 -0500
commit1ae0b08d1ad384f85e72fa40835ee68992aee150 (patch)
tree2f4866afef62016a34444d381a59ee44ed926634 /lib/sisu/v3/options.rb
parentdebian/changelog (3.1.8-1) (diff)
parentv3: html, seg output, index.html fixes (diff)
Merge commit 'sisu_3.1.9' into debian/sid
Diffstat (limited to 'lib/sisu/v3/options.rb')
-rw-r--r--lib/sisu/v3/options.rb7
1 files changed, 6 insertions, 1 deletions
diff --git a/lib/sisu/v3/options.rb b/lib/sisu/v3/options.rb
index ffd0da0f..b9d54123 100644
--- a/lib/sisu/v3/options.rb
+++ b/lib/sisu/v3/options.rb
@@ -131,7 +131,12 @@ module SiSU_commandline
if find_flag \
&& y !~ /^-/ \
&& y =~ /\S+/
- f << y
+ if y !~/\//
+ f << y
+ else
+ find_flag=false
+ puts %{sub-directories "#{y}" cannot be provided for --find or --glob at this time}
+ end
end
end
r=Px[:lng_lst].join('|')