aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/particulars.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-05-06 23:57:48 -0400
committerRalph Amissah <ralph@amissah.com>2012-05-06 23:57:48 -0400
commite3e9d55838d36fe07116c5a78fb1a1e5ff38f69b (patch)
treef99176d021ff9a42c9b6ec9bf6e68ebfc4ff30c1 /lib/sisu/v3/particulars.rb
parentdebian/changelog (3.2.6-1) (diff)
parentv3: hub, options, fixes: dbi: pgsql, sqlite (diff)
Merge tag 'sisu_3.2.7' into debian/sid
Diffstat (limited to 'lib/sisu/v3/particulars.rb')
-rw-r--r--lib/sisu/v3/particulars.rb50
1 files changed, 40 insertions, 10 deletions
diff --git a/lib/sisu/v3/particulars.rb b/lib/sisu/v3/particulars.rb
index 7c599624..e183d4c8 100644
--- a/lib/sisu/v3/particulars.rb
+++ b/lib/sisu/v3/particulars.rb
@@ -132,7 +132,10 @@ module SiSU_Particulars
begin
@md=SiSU_Param::Parameters.new(@opt).get
self
- rescue; SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error
+ rescue
+ SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error do
+ __LINE__.to_s + ':' + __FILE__
+ end
end
end
attr_accessor :opt,:env,:file
@@ -140,7 +143,10 @@ module SiSU_Particulars
begin
@env=SiSU_Env::InfoEnv.new(@opt.fns)
self
- rescue; SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error
+ rescue
+ SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error do
+ __LINE__.to_s + ':' + __FILE__
+ end
end
end
def set_file
@@ -148,7 +154,10 @@ module SiSU_Particulars
set_md unless @md
@file=SiSU_Env::FileOp.new(@md)
self
- rescue; SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error
+ rescue
+ SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error do
+ __LINE__.to_s + ':' + __FILE__
+ end
end
end
attr_accessor :opt,:dal_array
@@ -156,35 +165,50 @@ module SiSU_Particulars
begin
@dal_array=@dal_array=SiSU_DAL::Source.new(@md).get
self
- rescue; SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error
+ rescue
+ SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error do
+ __LINE__.to_s + ':' + __FILE__
+ end
end
end
def set_sst_idx
begin
@sst_idx=SiSU_DAL::Source.new(@md).get_idx_sst
self
- rescue; SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error
+ rescue
+ SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error do
+ __LINE__.to_s + ':' + __FILE__
+ end
end
end
def set_tex_idx
begin
@tex_idx=SiSU_DAL::Source.new(@md).get_idx_tex
self
- rescue; SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error
+ rescue
+ SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error do
+ __LINE__.to_s + ':' + __FILE__
+ end
end
end
def set_html_idx
begin
@html_idx=SiSU_DAL::Source.new(@md).get_idx_html
self
- rescue; SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error
+ rescue
+ SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error do
+ __LINE__.to_s + ':' + __FILE__
+ end
end
end
def set_xhtml_idx
begin
@xhtml_idx=SiSU_DAL::Source.new(@md).get_idx_xhtml
self
- rescue; SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error
+ rescue
+ SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error do
+ __LINE__.to_s + ':' + __FILE__
+ end
end
end
attr_accessor :nametags_map
@@ -193,7 +217,10 @@ module SiSU_Particulars
opt=@md ? @md : @opt
@nametags_map=SiSU_DAL::Source.new(opt).get_map_nametags
self
- rescue; SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error
+ rescue
+ SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error do
+ __LINE__.to_s + ':' + __FILE__
+ end
end
end
attr_accessor :ocn_htmlseg_map
@@ -201,7 +228,10 @@ module SiSU_Particulars
begin
@ocn_htmlseg_map=SiSU_DAL::Source.new(@md).get_map_ocn_htmlseg
self
- rescue; SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error
+ rescue
+ SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error do
+ __LINE__.to_s + ':' + __FILE__
+ end
end
end
end