aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/response.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-12-12 14:58:58 -0500
committerRalph Amissah <ralph@amissah.com>2012-12-12 14:58:58 -0500
commit1beb5aa3c376dbef89bc33024216650529ef7262 (patch)
tree1682500089c14fd49bcf52a3a001e291fadd5f75 /lib/sisu/v3/response.rb
parentdebian/changelog (3.3.2-1) (diff)
parentv3: 3.3.3 version & changelog, dates touched (diff)
Merge tag 'sisu_3.3.3' into debian/sid
Diffstat (limited to 'lib/sisu/v3/response.rb')
-rw-r--r--lib/sisu/v3/response.rb6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/sisu/v3/response.rb b/lib/sisu/v3/response.rb
index 675b249e..d660d398 100644
--- a/lib/sisu/v3/response.rb
+++ b/lib/sisu/v3/response.rb
@@ -61,9 +61,9 @@ module SiSU_Response
response='redo'
print ask + " ['yes', 'no' or 'quit']: "
response=File.new('/dev/tty').gets.strip
- ans=if response=='yes'; true
- elsif response=='no'; false
- elsif response =~/^quit|exit$/; exit
+ ans=if response=='yes' then true
+ elsif response=='no' then false
+ elsif response =~/^quit|exit$/ then exit
else puts "[please type: 'yes', 'no' or 'quit']"
response?(ask)
end