aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/rexml.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2011-04-20 21:10:04 -0400
committerRalph Amissah <ralph@amissah.com>2011-04-20 21:10:04 -0400
commit0f740e9c185b6aaed05e193828545ce7664fdbec (patch)
treed27e2672ad3a816c743ad65ac3de85e1eb237f46 /lib/sisu/v3/rexml.rb
parentdebian/changelog (3.0.6-1) (diff)
parentv2 v3: sisu-mode.el, header notes copyright assignment to FSF (GNU EMACS) (diff)
Merge branch 'upstream' into debian/sid
Diffstat (limited to 'lib/sisu/v3/rexml.rb')
-rw-r--r--lib/sisu/v3/rexml.rb10
1 files changed, 5 insertions, 5 deletions
diff --git a/lib/sisu/v3/rexml.rb b/lib/sisu/v3/rexml.rb
index d3053ee9..fd15865f 100644
--- a/lib/sisu/v3/rexml.rb
+++ b/lib/sisu/v3/rexml.rb
@@ -88,10 +88,10 @@ module SiSU_Rexml
xmlfile=IO.readlines(@fnap,'').join
begin
@xmldoc=REXML::Document.new xmlfile
- SiSU_Screen::Ansi.new(@md.cmd,'invert','REXML',"XML document #{@fnap} loaded").colorize unless @md.cmd =~/q/ #% tell
- if @md.cmd =~ /v/i #% substantive text
+ SiSU_Screen::Ansi.new(@md.opt.cmd,'invert','REXML',"XML document #{@fnap} loaded").colorize unless @md.opt.cmd =~/q/ #% tell
+ if @md.opt.cmd =~ /v/i #% substantive text
@xmldoc.elements.each(@e_head) do |e|
- SiSU_Screen::Ansi.new(@md.cmd,'brown',e).colorize unless @md.cmd =~/q/
+ SiSU_Screen::Ansi.new(@md.opt.cmd,'brown',e).colorize unless @md.opt.cmd =~/q/
end
end
rescue REXML::ParseException
@@ -99,10 +99,10 @@ module SiSU_Rexml
end
end
else
- SiSU_Screen::Ansi.new(@md.cmd,'fuschia',"File Not Found #{xmlfile}",'requested XML processing skipped').colorize unless @md.cmd =~/q/
+ SiSU_Screen::Ansi.new(@md.opt.cmd,'fuschia',"File Not Found #{xmlfile}",'requested XML processing skipped').colorize unless @md.opt.cmd =~/q/
exit
end
- rescue; SiSU_Errors::Info_error.new($!,$@,@md.cmd,@md.fns).error
+ rescue; SiSU_Errors::Info_error.new($!,$@,@md.opt.cmd,@md.fns).error
ensure
end
end