aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/sysenv.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-06-06 23:54:36 -0400
committerRalph Amissah <ralph@amissah.com>2012-06-06 23:54:36 -0400
commite02c0129e10e4ed8e102978df31a7e370f5b868b (patch)
tree475e987720aaccce8f6c0cadb53649a589b893a2 /lib/sisu/v3/sysenv.rb
parentdebian/changelog (3.2.11-1) (diff)
parentv3: hub, post bundles, sisupod_make, file selection selection for tar.xz, fix (diff)
Merge tag 'sisu_3.2.12' into debian/sid
Diffstat (limited to 'lib/sisu/v3/sysenv.rb')
-rw-r--r--lib/sisu/v3/sysenv.rb3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/sisu/v3/sysenv.rb b/lib/sisu/v3/sysenv.rb
index b8dd37b0..5e9533a2 100644
--- a/lib/sisu/v3/sysenv.rb
+++ b/lib/sisu/v3/sysenv.rb
@@ -5647,7 +5647,8 @@ WOK
@env=SiSU_Env::InfoEnv.new
end
def apply
- if @md.make.skin
+ if @m.respond_to?(:make) \
+ and @md.make.respond_to(:skin)
skin_path=unless @md.opt.f_pth[:pth] =~/\/\S+?\/sisupod\/\S+?\/sisupod\/doc/
[
"#{@env.path.pwd}/_sisu/skin",