aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/xml_tables.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-12-12 14:58:58 -0500
committerRalph Amissah <ralph@amissah.com>2012-12-12 14:58:58 -0500
commit1beb5aa3c376dbef89bc33024216650529ef7262 (patch)
tree1682500089c14fd49bcf52a3a001e291fadd5f75 /lib/sisu/v3/xml_tables.rb
parentdebian/changelog (3.3.2-1) (diff)
parentv3: 3.3.3 version & changelog, dates touched (diff)
Merge tag 'sisu_3.3.3' into debian/sid
Diffstat (limited to 'lib/sisu/v3/xml_tables.rb')
-rw-r--r--lib/sisu/v3/xml_tables.rb12
1 files changed, 4 insertions, 8 deletions
diff --git a/lib/sisu/v3/xml_tables.rb b/lib/sisu/v3/xml_tables.rb
index 98dc0140..ba89e791 100644
--- a/lib/sisu/v3/xml_tables.rb
+++ b/lib/sisu/v3/xml_tables.rb
@@ -97,11 +97,9 @@ module SiSU_Tables
if @parablock =~/#{Mx[:tc_p]}#{Mx[:tc_p]}/u
@parablock=@parablock.gsub(/#{Mx[:tc_o]}#{Mx[:tc_p]}#{Mx[:tc_p]}(\d+?)#{Mx[:tc_p]}/u,
%{<tr>
- <td width="\\1%" valign="top">
- #{@vz.paragraph_table_xml}<b>}).
+ <td width="\\1%" valign="top"><b>}).
gsub(/#{Mx[:tc_p]}#{Mx[:tc_p]}(\d+?)#{Mx[:tc_p]}/u,
- %{</b></td><td width="\\1%" valign="top">
- #{@vz.paragraph_table_xml}<b>}).
+ %{</b></td><td width="\\1%" valign="top"><b>}).
gsub(/#{Mx[:tc_c]}/,"</b>\n</td>\n</tr>")
@@tablehead=0
end
@@ -109,13 +107,11 @@ module SiSU_Tables
else
@parablock=@parablock.gsub(/#{Mx[:tc_o]}#{Mx[:tc_p]}#{Mx[:tc_p]}(\d+?)#{Mx[:tc_p]}/u,
%{<tr>
- <td width="\\1%" valign="top">
- #{@vz.paragraph_table_xml}}).
+ <td width="\\1%" valign="top">}).
gsub(/#{Mx[:tc_p]}#{Mx[:tc_p]}(\d+?)#{Mx[:tc_p]}/u,
%{
</td>
- <td width="\\1%" valign="top">
- #{@vz.paragraph_table_xml}}).
+ <td width="\\1%" valign="top">}).
gsub(/#{Mx[:tc_c]}/,"\n</td>\n</tr>\n")
end
@parablock