aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v4/dal_misc_arrange.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-08-28 18:22:27 -0400
committerRalph Amissah <ralph@amissah.com>2013-08-28 18:22:27 -0400
commitdbddd3289c1a7bad5b549698af0a58aa568fcc43 (patch)
treece801cb01286a340ae0220ab74dcaae986e800d7 /lib/sisu/v4/dal_misc_arrange.rb
parentdebian/changelog (4.2.0-1) (diff)
parentv5: dal, grouped text with fontface spanning newlines, partial solution, test (diff)
Merge tag 'sisu_4.2.1' into debian/sid
SiSU 4.2.1
Diffstat (limited to 'lib/sisu/v4/dal_misc_arrange.rb')
-rw-r--r--lib/sisu/v4/dal_misc_arrange.rb6
1 files changed, 4 insertions, 2 deletions
diff --git a/lib/sisu/v4/dal_misc_arrange.rb b/lib/sisu/v4/dal_misc_arrange.rb
index ab4f3ea4..e6cc72db 100644
--- a/lib/sisu/v4/dal_misc_arrange.rb
+++ b/lib/sisu/v4/dal_misc_arrange.rb
@@ -78,8 +78,10 @@ module SiSU_DAL_MiscArrangeText
block_open,block_close,text=nil,nil,nil
if para =~/\A[`]{3}\s+.+?\n.+?\n[`]{3}(?:\s+[~-][#]|\s+\~\{.+?\}\~)?\s*\Z/m
block_open,text,block_close=/\A([`]{3}\s+.+?)\n(.+?)\n([`]{3}(\s+[~-][#]|\s+\~\{.+?\}\~)?)\s*\Z/m.match(para)[1..3]
- para=[]
- para << block_open << text << block_close
+ ((para=~/^[`]{3}\s+table(?:~h)?\s+/) \
+ and (para !~/^[`]{3}\s+table(?:~h)?\s+c\d+/)) \
+ ? para
+ : (para=[]; para << block_open << text << block_close)
elsif para =~/\A[`]{3}\s+.+?\n.*?\Z/m #look at, study
block_open,text=/\A([`]{3}(?:\s+.+?))\n(.*?)\Z/m.match(para)[1,2]
para=[]