aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v4/epub_segments.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-01-31 21:41:55 -0500
committerRalph Amissah <ralph@amissah.com>2013-01-31 21:41:55 -0500
commitee132f1146cbed3266b448e1cea312375c201cf1 (patch)
tree37498d07d78fa16e21361ccbefeb2adc0d9e6039 /lib/sisu/v4/epub_segments.rb
parentdebian/changelog (4.0.3-1) (diff)
parentv4 (v3): version & changelog, dates touched (diff)
Merge tag 'sisu_4.0.4' into debian/sid
Diffstat (limited to 'lib/sisu/v4/epub_segments.rb')
-rw-r--r--lib/sisu/v4/epub_segments.rb6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/sisu/v4/epub_segments.rb b/lib/sisu/v4/epub_segments.rb
index e2727232..007e4672 100644
--- a/lib/sisu/v4/epub_segments.rb
+++ b/lib/sisu/v4/epub_segments.rb
@@ -305,7 +305,7 @@ WOK
txt_obj={ txt: @@heading1, ocn_display: @p_num.ocn_display }
format_seg=SiSU_EPUB_Format::FormatSeg.new(@md,txt_obj)
@@seg[:headings] << format_seg.title_heading1.gsub(clean,'')
- @@heading1=@@heading1.gsub(/&nbsp;<a name="-[\d*+]+" href="#_[\d*+]+">&nbsp;<sup>[\d*+]+<\/sup>&nbsp;<\/a>/,'')
+ @@heading1=@@heading1.gsub(/#{$ep[:hsp]}<a name="-[\d*+]+" href="#_[\d*+]+">#{$ep[:hsp]}<sup>[\d*+]+<\/sup>#{$ep[:hsp]}<\/a>/,'')
end
if @@is2==1
heading2=@@heading2
@@ -316,7 +316,7 @@ WOK
txt_obj={ txt: heading2, ocn_display: @p_num.ocn_display }
format_seg=SiSU_EPUB_Format::FormatSeg.new(@md,txt_obj)
@@seg[:headings] << format_seg.title_heading2.gsub(clean,'')
- @@heading2=@@heading2.gsub(/&nbsp;<a name="-[\d*+]+" href="#_[\d*+]+">&nbsp;<sup>[\d*+]+<\/sup>&nbsp;<\/a>/,'')
+ @@heading2=@@heading2.gsub(/#{$ep[:hsp]}<a name="-[\d*+]+" href="#_[\d*+]+">#{$ep[:hsp]}<sup>[\d*+]+<\/sup>#{$ep[:hsp]}<\/a>/,'')
end
if @@is3==1
heading3=@@heading3
@@ -327,7 +327,7 @@ WOK
txt_obj={ txt: heading3, ocn_display: @p_num.ocn_display }
format_seg=SiSU_EPUB_Format::FormatSeg.new(@md,txt_obj)
@@seg[:headings] << format_seg.title_heading3.gsub(clean,'')
- @@heading3=@@heading3.gsub(/&nbsp;<a name="-[\d*+]+" href="#_[\d*+]+">&nbsp;<sup>[\d*+]+<\/sup>&nbsp;<\/a>/,'')
+ @@heading3=@@heading3.gsub(/#{$ep[:hsp]}<a name="-[\d*+]+" href="#_[\d*+]+">#{$ep[:hsp]}<sup>[\d*+]+<\/sup>#{$ep[:hsp]}<\/a>/,'')
end
if @@is4==1
heading4=@@heading4