aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v4/html_table.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-12-12 15:07:22 -0500
committerRalph Amissah <ralph@amissah.com>2012-12-12 15:07:22 -0500
commitdb23b42728ad667d328af2cd3759cc47091eade3 (patch)
tree804f5f7042b603315ed917f2428845547f8836c3 /lib/sisu/v4/html_table.rb
parentdebian/changelog (3.3.3-1) (diff)
parentv4: 4.0.0 version & changelog, dates touched (diff)
Merge tag 'sisu_4.0.0' into debian/sid
Diffstat (limited to 'lib/sisu/v4/html_table.rb')
-rw-r--r--lib/sisu/v4/html_table.rb64
1 files changed, 64 insertions, 0 deletions
diff --git a/lib/sisu/v4/html_table.rb b/lib/sisu/v4/html_table.rb
new file mode 100644
index 00000000..f94199ce
--- /dev/null
+++ b/lib/sisu/v4/html_table.rb
@@ -0,0 +1,64 @@
+# encoding: utf-8
+=begin
+
+ * Name: SiSU
+
+ * Description: a framework for document structuring, publishing and search
+
+ * Author: Ralph Amissah
+
+ * Copyright: (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006,
+ 2007, 2008, 2009, 2010, 2011, 2012 Ralph Amissah, All Rights Reserved.
+
+ * License: GPL 3 or later:
+
+ SiSU, a framework for document structuring, publishing and search
+
+ Copyright (C) Ralph Amissah
+
+ This program is free software: you can redistribute it and/or modify it
+ under the terms of the GNU General Public License as published by the Free
+ Software Foundation, either version 3 of the License, or (at your option)
+ any later version.
+
+ This program is distributed in the hope that it will be useful, but WITHOUT
+ ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+ FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for
+ more details.
+
+ You should have received a copy of the GNU General Public License along with
+ this program. If not, see <http://www.gnu.org/licenses/>.
+
+ If you have Internet connection, the latest version of the GPL should be
+ available at these locations:
+ <http://www.fsf.org/licensing/licenses/gpl.html>
+ <http://www.gnu.org/licenses/gpl.html>
+
+ <http://www.sisudoc.org/sisu/en/manifest/gpl.fsf.html>
+
+ * SiSU uses:
+ * Standard SiSU markup syntax,
+ * Standard SiSU meta-markup syntax, and the
+ * Standard SiSU object citation numbering and system
+
+ * Hompages:
+ <http://www.jus.uio.no/sisu>
+ <http://www.sisudoc.org>
+
+ * Download:
+ <http://www.sisudoc.org/sisu/en/SiSU/download.html>
+
+ * Ralph Amissah
+ <ralph@amissah.com>
+ <ralph.amissah@gmail.com>
+
+ ** Description: shared html parts
+
+=end
+module SiSU_HTML_Table
+ require_relative 'defaults' # defaults.rb
+ require_relative 'xhtml_table.rb' # xhtml_table.rb
+ class TableHTML <SiSU_XHTML_Table::TableXHTML
+ end
+end
+__END__