aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v4/urls.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-02-04 00:11:52 -0500
committerRalph Amissah <ralph@amissah.com>2013-02-04 00:11:52 -0500
commitb509e362a21e86e95cc46ff582db1f8e2bc14319 (patch)
tree7911fb8f6a2b4784f70ad7dd90f2744e0dbeed31 /lib/sisu/v4/urls.rb
parentdebian/changelog (4.0.4-1) (diff)
parentv4: documentation, include --html-scroll and --html-seg options (diff)
Merge tag 'sisu_4.0.5' into debian/sid
Diffstat (limited to 'lib/sisu/v4/urls.rb')
-rw-r--r--lib/sisu/v4/urls.rb12
1 files changed, 9 insertions, 3 deletions
diff --git a/lib/sisu/v4/urls.rb b/lib/sisu/v4/urls.rb
index a9a27bff..5e6bcc8a 100644
--- a/lib/sisu/v4/urls.rb
+++ b/lib/sisu/v4/urls.rb
@@ -316,11 +316,17 @@ module SiSU_Urls
show.epub(x)
end
if x=~/--html\b/ \
- and @opt.act[:html][:set]==:on
+ and (@opt.act[:html][:set]==:on \
+ or @opt.act[:html_scroll][:set]==:on \
+ or @opt.act[:html_seg][:set]==:on)
if x =~/scroll/
- show.html.scroll(x)
+ if @opt.act[:html_scroll][:set]==:on
+ show.html.scroll(x)
+ end
else
- show.html.toc(x)
+ if @opt.act[:html_seg][:set]==:on
+ show.html.toc(x)
+ end
end
end
if x=~/--texinfo\b/ \