aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v5/harvest.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2014-08-08 00:38:36 -0400
committerRalph Amissah <ralph@amissah.com>2014-08-08 00:38:36 -0400
commitfe909890122d015ab05273e8d181b2b30765710f (patch)
treee922edaef0997e926a4983593ec088dcca7f7d77 /lib/sisu/v5/harvest.rb
parentdebian/changelog (5.5.6-1) (diff)
parentdocumentation related (diff)
Merge tag 'sisu_5.6.0' into debian/sid
SiSU 5.6.0
Diffstat (limited to 'lib/sisu/v5/harvest.rb')
-rw-r--r--lib/sisu/v5/harvest.rb4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/sisu/v5/harvest.rb b/lib/sisu/v5/harvest.rb
index cc12b08e..ddc85055 100644
--- a/lib/sisu/v5/harvest.rb
+++ b/lib/sisu/v5/harvest.rb
@@ -76,7 +76,7 @@ module SiSU_Harvest
end
def read
begin
- harvest_pth="#{@env.path.webserv}/#{@opt.base_stub}"
+ harvest_pth=@env.path.webserv + '/' + @opt.base_stub
FileUtils::mkdir_p(harvest_pth) unless FileTest.directory?(harvest_pth)
cases(@opt,@env)
rescue
@@ -99,7 +99,7 @@ WOK
style.close
end
def cases(opt,env)
- case opt.mod.inspect
+ case opt.selections.str.inspect
when/--harvest/i
css(opt) if @opt.act[:maintenance][:set]==:on
SiSU_HarvestAuthors::Songsheet.new(opt,env).songsheet