aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v5/se_filemap.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2014-08-08 00:38:36 -0400
committerRalph Amissah <ralph@amissah.com>2014-08-08 00:38:36 -0400
commitfe909890122d015ab05273e8d181b2b30765710f (patch)
treee922edaef0997e926a4983593ec088dcca7f7d77 /lib/sisu/v5/se_filemap.rb
parentdebian/changelog (5.5.6-1) (diff)
parentdocumentation related (diff)
Merge tag 'sisu_5.6.0' into debian/sid
SiSU 5.6.0
Diffstat (limited to 'lib/sisu/v5/se_filemap.rb')
-rw-r--r--lib/sisu/v5/se_filemap.rb4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/sisu/v5/se_filemap.rb b/lib/sisu/v5/se_filemap.rb
index 0c4c84c0..075cdb83 100644
--- a/lib/sisu/v5/se_filemap.rb
+++ b/lib/sisu/v5/se_filemap.rb
@@ -68,7 +68,7 @@ module SiSU_File_Map
attr_accessor :local_sisu_source
def initialize(opt='') #watch / REVIEW
super()
- @opt=opt #,opt.fns,opt.cmd
+ @opt=opt #,opt.fns,opt.selections.str
@env=(@opt.fns && !(@opt.fns.empty?) \
? (SiSU_Env::InfoEnv.new(@opt.fns))
: (SiSU_Env::InfoEnv.new('dummy.sst')))
@@ -216,7 +216,7 @@ module SiSU_File_Map
ft=ft.uniq
filetypes=ft.join(',')
@filetypes=if filetypes !~/..+/ then '' # -r called alone, copy all
- elsif @opt.cmd =~/u/ then '' # -u added, copy all, (used to create remote directory tree see output path), not the usual function of -u
+ elsif @opt.selections.str =~/u/ then '' # -u added, copy all, (used to create remote directory tree see output path), not the usual function of -u
elsif filetypes =~/\S+?,\S+/ then '*{' + filetypes + '}' # more than one relevant file type
else '*' + filetypes # one relevant file type
end