aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v6/db_create.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2014-08-08 00:38:36 -0400
committerRalph Amissah <ralph@amissah.com>2014-08-08 00:38:36 -0400
commitfe909890122d015ab05273e8d181b2b30765710f (patch)
treee922edaef0997e926a4983593ec088dcca7f7d77 /lib/sisu/v6/db_create.rb
parentdebian/changelog (5.5.6-1) (diff)
parentdocumentation related (diff)
Merge tag 'sisu_5.6.0' into debian/sid
SiSU 5.6.0
Diffstat (limited to 'lib/sisu/v6/db_create.rb')
-rw-r--r--lib/sisu/v6/db_create.rb7
1 files changed, 5 insertions, 2 deletions
diff --git a/lib/sisu/v6/db_create.rb b/lib/sisu/v6/db_create.rb
index 4d551ee2..55eab144 100644
--- a/lib/sisu/v6/db_create.rb
+++ b/lib/sisu/v6/db_create.rb
@@ -264,6 +264,7 @@ module SiSU_DbCreate
lev4 SMALLINT,
lev5 SMALLINT,
lev6 SMALLINT,
+ lev7 SMALLINT,
en_a SMALLINT NULL,
en_z SMALLINT NULL,
en_a_asterisk SMALLINT NULL,
@@ -506,9 +507,9 @@ module SiSU_DbCreate
%{COMMENT ON COLUMN doc_objects.metadata_tid
IS 'tie to title in metadata_and_text';},
%{COMMENT ON COLUMN doc_objects.lev_an
- IS 'doc level A-D 1-6';},
+ IS 'doc level A-D 1-4';},
%{COMMENT ON COLUMN doc_objects.lev
- IS 'doc level 0-6 \d\~';},
+ IS 'doc level 0-7 \d\~';},
%{COMMENT ON COLUMN doc_objects.seg
IS 'segment name from level number 4 (lv 1)';},
%{COMMENT ON COLUMN doc_objects.ocn
@@ -547,6 +548,8 @@ module SiSU_DbCreate
IS 'document structure, level number 5';},
%{COMMENT ON COLUMN doc_objects.lev6
IS 'document structure, level number 6';},
+ %{COMMENT ON COLUMN doc_objects.lev7
+ IS 'document structure, level number 7';},
%{COMMENT ON COLUMN doc_objects.t_of
IS 'document structure, type of object (object is of)';},
%{COMMENT ON COLUMN doc_objects.t_is