aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v6/se_db.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2014-08-12 00:13:56 -0400
committerRalph Amissah <ralph@amissah.com>2014-08-12 00:13:56 -0400
commit9eae7919e8fbdca44578c4bd870a561d0458eaed (patch)
treeb3e011a68039675a3b994a79ea44b4e9fbac22d0 /lib/sisu/v6/se_db.rb
parentdebian/changelog (5.6.0-1) (diff)
parentv5 v6: hub, organisation & loose ends (diff)
Merge tag 'sisu_5.6.1' into debian/sid
SiSU 5.6.1
Diffstat (limited to 'lib/sisu/v6/se_db.rb')
-rw-r--r--lib/sisu/v6/se_db.rb4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/sisu/v6/se_db.rb b/lib/sisu/v6/se_db.rb
index 542b4ef3..ac226675 100644
--- a/lib/sisu/v6/se_db.rb
+++ b/lib/sisu/v6/se_db.rb
@@ -94,10 +94,10 @@ module SiSU_Info_Db
def psql
def user(opt=nil)
if opt \
- and opt.selections.str.inspect =~/--db-user[=-]["']?(\S+)["']+/
+ and opt.selections.str =~/--db-user[=-]["']?(\S+)["']+/
$1
elsif opt \
- and opt.mod =~/--webserv[=-]webrick/
+ and opt.selections.str =~/--webserv[=-]webrick/
@env.user
else
((defined? @rc['db']['postgresql']['user']) \