diff options
author | Ralph Amissah <ralph.amissah@gmail.com> | 2022-04-10 13:49:46 -0400 |
---|---|---|
committer | Ralph Amissah <ralph.amissah@gmail.com> | 2022-04-19 13:42:45 -0400 |
commit | 338db72033d06f052b91c291c77bfbf687890f23 (patch) | |
tree | 09f565c6dc40e6f35cf577ad386a29f4ddbddcc0 /shell.nix | |
parent | ruby variable passing breakage, make constant? (diff) |
project config minor, also .gitignoresisu_7.2.1
Diffstat (limited to 'shell.nix')
-rwxr-xr-x | shell.nix | 39 |
1 files changed, 20 insertions, 19 deletions
@@ -1,27 +1,28 @@ #!/usr/bin/env -S nix-shell --pure { pkgs ? import <nixpkgs> {} }: -pkgs.mkShell { - buildInputs = [( - with pkgs; [ - ruby_3_1 - rubyPackages_3_1.rake - rubyPackages_3_1.sqlite3 - rubyPackages_3_1.thor - sqlite - unzip - xz - zip - openssl - #texlive-combined-full - nixFlakes - validatePkgConfig - jq - git - ] - )]; +with pkgs; +mkShell { + buildInputs = [ + ruby_3_1 + rubyPackages_3_1.rake + rubyPackages_3_1.sqlite3 + rubyPackages_3_1.thor + sqlite + unzip + xz + zip + openssl + #texlive-combined-full + nixFlakes + validatePkgConfig + jq + git + starship + ]; shellHook = '' if [[ -e ".envrc" ]]; then source .envrc fi + eval "$(starship init bash)" ''; } |