aboutsummaryrefslogtreecommitdiffhomepage
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix16
1 files changed, 13 insertions, 3 deletions
diff --git a/default.nix b/default.nix
index ab10c24..5ffb598 100644
--- a/default.nix
+++ b/default.nix
@@ -1,7 +1,17 @@
-{ pkgs ? import <nixpkgs> {}, }:
+{ pkgs ? import <nixpkgs> {},
+ stdenv ? pkgs.stdenv,
+}:
with import ./mkDub.nix { inherit pkgs; };
-mkDubDerivation {
- version = "0.11.1"; # optional
+mkDubDerivation rec {
+ name = "spine-${version}";
+ version = "0.11.1";
src = ./.;
buildInputs = [ pkgs.sqlite ];
+ meta = with stdenv.lib; {
+ homepage = http://sisudoc.org;
+ description = "a sisu like document parser";
+ license = licenses.agpl3Plus;
+ platforms = platforms.linux;
+ maintainers = [ Ralph Amissah ];
+ };
}