aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100755
index 00000000..a22a36d4
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,28 @@
+#!/usr/bin/env -S nix-shell --impure
+#!nix-shell -i bash
+{pkgs ? import <nixpkgs> {}}:
+with pkgs;
+ mkShell {
+ buildInputs = [
+ ruby_3_1
+ rubyPackages_3_1.rake
+ rubyPackages_3_1.sqlite3
+ rubyPackages_3_1.thor
+ sqlite
+ graphicsmagick
+ unzip
+ xz
+ zip
+ openssl
+ #texlive-combined-full
+ nixFlakes
+ validatePkgConfig
+ nix-output-monitor
+ nix-tree
+ jq
+ git
+ #starship
+ ];
+ shellHook = ''
+ '';
+ }