aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rwxr-xr-x[-rw-r--r--]shell.nix34
1 files changed, 28 insertions, 6 deletions
diff --git a/shell.nix b/shell.nix
index 34300f62..a22a36d4 100644..100755
--- a/shell.nix
+++ b/shell.nix
@@ -1,6 +1,28 @@
-{ pkgs ? import <nixpkgs> {} }:
-pkgs.mkShell {
- buildInputs = [
- (import ./packages.nix { inherit pkgs; })
- ];
-}
+#!/usr/bin/env -S nix-shell --impure
+#!nix-shell -i bash
+{pkgs ? import <nixpkgs> {}}:
+with pkgs;
+ mkShell {
+ buildInputs = [
+ ruby_3_1
+ rubyPackages_3_1.rake
+ rubyPackages_3_1.sqlite3
+ rubyPackages_3_1.thor
+ sqlite
+ graphicsmagick
+ unzip
+ xz
+ zip
+ openssl
+ #texlive-combined-full
+ nixFlakes
+ validatePkgConfig
+ nix-output-monitor
+ nix-tree
+ jq
+ git
+ #starship
+ ];
+ shellHook = ''
+ '';
+ }