aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rwxr-xr-x[-rw-r--r--]shell.nix27
1 files changed, 24 insertions, 3 deletions
diff --git a/shell.nix b/shell.nix
index 34300f62..5c0baa18 100644..100755
--- a/shell.nix
+++ b/shell.nix
@@ -1,6 +1,27 @@
+#!/usr/bin/env -S nix-shell --pure
{ pkgs ? import <nixpkgs> {} }:
pkgs.mkShell {
- buildInputs = [
- (import ./packages.nix { inherit pkgs; })
- ];
+ buildInputs = [(
+ with pkgs; [
+ ruby_3_0
+ rubyPackages_3_0.rake
+ rubyPackages_3_0.sqlite3
+ rubyPackages_3_0.thor
+ sqlite
+ unzip
+ xz
+ zip
+ openssl
+ #texlive-combined-full
+ nixFlakes
+ validatePkgConfig
+ jq
+ git
+ ]
+ )];
+ shellHook = ''
+ if [[ -e ".envrc" ]]; then
+ source .envrc
+ fi
+ '';
}