summaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2024-03-09 20:10:02 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2024-03-10 15:45:11 -0400
commitca590402ad0d3aefd35d51bdfc016cac9453a47c (patch)
tree15b12d0fec8a8c30693a48699d2fd84e53d5e3a3 /shell.nix
parentdmd & ldc upkeep (dmd at 2.106.1) (diff)
nix flake & env upkeep
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix13
1 files changed, 7 insertions, 6 deletions
diff --git a/shell.nix b/shell.nix
index 7aa977b..e44c85e 100755
--- a/shell.nix
+++ b/shell.nix
@@ -1,7 +1,7 @@
#!/usr/bin/env -S nix-shell --pure
#!nix-shell -i bash
-{pkgs ? import <nixpkgs> {}}:
-with pkgs;
+{pkgs-nix ? import <nixpkgs> {}}:
+with pkgs-nix;
mkShell {
buildInputs = [
# ❯❯❯ nix_related
@@ -12,17 +12,18 @@ with pkgs;
validatePkgConfig
nix-output-monitor
nix-tree
- jq
- alejandra
+ jq #gx
+ #alejandra
git
# ❯❯❯ dev
gnumake
ps
# ❯❯❯ d_build_related
# ❯❯ package manager
- dub
+ #dub
# ❯❯ compiler
- ldc
+ #dmd
+ #ldc
#rund
# ❯❯ linker
#lld