aboutsummaryrefslogtreecommitdiffhomepage
path: root/default.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2020-10-13 14:09:43 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2020-10-19 14:43:00 -0400
commit2d9778dc01c8ca6c5a915e1ee638251878990d10 (patch)
tree27a850e0eaf74937f78e7486552510cf954bc620 /default.nix
parentnixify step (diff)
build nix derivation (using dub2nix helper tool)
- nix-shell - nix-build - dub2nix (dub to nix helper tool) - Lionello Lunesu - MIT License - https://github.com/lionello/dub2nix
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..ab10c24
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,7 @@
+{ pkgs ? import <nixpkgs> {}, }:
+with import ./mkDub.nix { inherit pkgs; };
+mkDubDerivation {
+ version = "0.11.1"; # optional
+ src = ./.;
+ buildInputs = [ pkgs.sqlite ];
+}