aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2022-11-25 20:50:40 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2022-12-23 18:15:52 -0500
commit4c089543a4ac61ac21dab814c0dc114d48f42c36 (patch)
tree0b1da4c4c7c3d73c40dbef2fdfc604686d72dfe6 /flake.nix
parentepub header assertion removed, check (diff)
0.12.0
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix20
1 files changed, 9 insertions, 11 deletions
diff --git a/flake.nix b/flake.nix
index 5bb4716..c188d21 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,10 +1,8 @@
{
- description = "A sisu like parser and document generator";
- inputs = {
- flake-utils.url = "github:numtide/flake-utils";
- nixpkgs.url = "github:nixos/nixpkgs";
- #nixpkgs.url = "/nixpkgs-ra/nixpkgs";
- };
+ description = "a sisu like parser and document generator";
+ inputs.flake-utils.url = "github:numtide/flake-utils";
+ inputs.nixpkgs.url = "github:nixos/nixpkgs";
+ #inputs.nixpkgs.url = "/nixpkgs-ra/nixpkgs";
outputs = { self, nixpkgs, flake-utils }: {
packages.x86_64-linux.spine =
let
@@ -14,8 +12,8 @@
#targetOf = package: "${package.targetPath or "."}/${package.targetName or package.name}";
in pkgs.stdenv.mkDerivation {
pname = "spine";
- version = "0.11.3";
- description = "A sisu like parser and document generator";
+ version = "0.12.0";
+ description = "a sisu like parser and document generator";
inherit self;
src = self;
shell = ./shell.nix;
@@ -26,9 +24,7 @@
for DC_ in dmd ldmd2 gdmd; do
echo "- check for D compiler $DC_"
DC=$(type -P $DC_ || echo "")
- if [ ! "$DC" == "" ]; then
- break
- fi
+ if [ ! "$DC" == "" ]; then break; fi
done
if [ "$DC" == "" ]; then
exit "Error: could not find D compiler"
@@ -51,6 +47,8 @@
runHook postInstall
'';
postInstall = ''
+ echo `ls -la $out/bin/spine`
+ echo ""
echo "nix build or nix develop? (suggestions):"
echo '- nix build'
echo ' nix build .#spine --print-build-logs'