aboutsummaryrefslogtreecommitdiffhomepage
path: root/nix/shell/meson.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2021-01-27 10:45:51 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2021-01-27 15:33:24 -0500
commitd0465e3837a71afae2f1a6f42eb923350d826e27 (patch)
tree7e2eda3dce2ee7199044ef2cc4f53652e593e261 /nix/shell/meson.nix
parentmkDub.nix project.nix spine.nix (diff)
shell.nix project.nix spine.nix mkDub.nix
Diffstat (limited to 'nix/shell/meson.nix')
-rwxr-xr-xnix/shell/meson.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/nix/shell/meson.nix b/nix/shell/meson.nix
new file mode 100755
index 0000000..8c06eb8
--- /dev/null
+++ b/nix/shell/meson.nix
@@ -0,0 +1,10 @@
+{ pkgs ? import <nixpkgs> {} }:
+pkgs.mkShell {
+ buildInputs = with pkgs; [
+ (import ../pkgs/meson-pkgs.nix { inherit pkgs; })
+ ];
+ shellHook = ''
+ meson setup --wipe build && ninja -v -C build
+ '';
+}
+# nix-shell nix/shell/meson.nix