aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2023-01-23 16:10:00 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2023-01-25 09:53:48 -0500
commita615ba442e4c175e957dd0f07086b877268635df (patch)
treef13ebcbd01b5ea6908b78d907fb267b5b20008e1 /shell.nix
parent2023, year rollover, old habit (diff)
nix & build housekeeping, alternative D compilers
- compilation status - dmd (@D2.100) ok, & has been fine - ldc (@D2.100) ok, & has been fine - gdc11 available in nixpkgs does not compile awaiting gdc12 (which would also be based on @D2.100 & just might)
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
index c31d0a6..8f86997 100755
--- a/shell.nix
+++ b/shell.nix
@@ -4,12 +4,14 @@
with pkgs;
mkShell {
buildInputs = [
+ #nix
direnv
nixVersions.unstable #nixFlakes
nix-prefetch-git
validatePkgConfig
nix-tree jq nix-output-monitor
git
+ gnumake
ps
### d_build_related
dub
@@ -91,6 +93,12 @@ mkShell {
nix-build . --no-out-link | xargs -o nix-tree
nix-tree --derivation .#default
+ nix flake update && nix flake check --show-trace && nix flake show && nix develop .#devShell
+ nix build .#default --print-build-logs
+
+ - nix build .#spine-dmd --print-build-logs
+ - nix build .#spine-ldc --print-build-logs
+ - nix build .#spine-gdc --print-build-logs
"
#echo "ldc `${pkgs.ldc}/bin/ldc2 -v`"
'';