aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2021-01-27 10:45:51 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2021-01-27 15:33:24 -0500
commitd0465e3837a71afae2f1a6f42eb923350d826e27 (patch)
tree7e2eda3dce2ee7199044ef2cc4f53652e593e261 /shell.nix
parentmkDub.nix project.nix spine.nix (diff)
shell.nix project.nix spine.nix mkDub.nix
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index 4edc4bd..941a217 100755
--- a/shell.nix
+++ b/shell.nix
@@ -2,10 +2,11 @@
{ pkgs ? import <nixpkgs> {} }:
pkgs.mkShell {
buildInputs = with pkgs; [
- (import ./nix/shell-packages.nix { inherit pkgs; })
+ (import ./nix/pkglst/shell-pkgs.nix { inherit pkgs; })
];
shellHook = ''
nix-build
echo "built spine @ ./result/bin/spine"
+ nix-instantiate | nix show-derivation | jq
'';
}