aboutsummaryrefslogtreecommitdiffhomepage
path: root/sundry/spine_search_cgi/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2022-11-25 20:51:34 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2022-12-23 18:15:52 -0500
commitfb112dca9c785a71eaf033732b87519a6575b3a8 (patch)
treeff689aa48548a84df8378df6b21fa268e628ae26 /sundry/spine_search_cgi/shell.nix
parent0.12.0 (diff)
spine-search-cgi separate commits, remove sundry
Diffstat (limited to 'sundry/spine_search_cgi/shell.nix')
-rwxr-xr-xsundry/spine_search_cgi/shell.nix40
1 files changed, 0 insertions, 40 deletions
diff --git a/sundry/spine_search_cgi/shell.nix b/sundry/spine_search_cgi/shell.nix
deleted file mode 100755
index d918d20..0000000
--- a/sundry/spine_search_cgi/shell.nix
+++ /dev/null
@@ -1,40 +0,0 @@
-#!/usr/bin/env -S nix-shell --pure
-{ pkgs ? import <nixpkgs> {} }:
-with pkgs;
-mkShell {
- buildInputs = [
- ### nix_related
- direnv
- nixVersions.unstable #nixFlakes
- nix-prefetch-git
- validatePkgConfig
- jq
- git
- ps
- ### d_build_related
- ## package manager
- dub
- ## compiler
- ldc
- rund
- ## linker
- #lld
- #mold
- ## builder
- #ninja
- #meson
- ### sqlite search related
- sqlite
- ### tools
- #curl
- #wget
- aria
- ### candy
- starship
- ];
- shellHook = ''
- if [[ -f ".envrc" ]]; then
- source .envrc
- fi
- '';
-}