aboutsummaryrefslogtreecommitdiffhomepage
path: root/sundry/spine_search_cgi/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2021-08-01 05:20:29 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2021-08-01 07:47:01 -0400
commitff590479eab42d472a9e219a41459f67ee8fcd3d (patch)
treee2d74b0a6f293aa2205639194ffda80a23ad2d72 /sundry/spine_search_cgi/shell.nix
parentdir rename ./sundry (from ./misc) (diff)
spine_search
Diffstat (limited to 'sundry/spine_search_cgi/shell.nix')
-rwxr-xr-xsundry/spine_search_cgi/shell.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/sundry/spine_search_cgi/shell.nix b/sundry/spine_search_cgi/shell.nix
new file mode 100755
index 0000000..7f37eee
--- /dev/null
+++ b/sundry/spine_search_cgi/shell.nix
@@ -0,0 +1,22 @@
+#!/usr/bin/env -S nix-shell --pure
+{ pkgs ? import <nixpkgs> {} }:
+pkgs.mkShell {
+ buildInputs = with pkgs; [(
+ with pkgs; [
+ nixFlakes
+ rund
+ dub
+ ldc
+ sqlite
+ nix-prefetch-git
+ validatePkgConfig
+ jq
+ git
+ ]
+ )];
+ shellHook = ''
+ if [[ -e ".envrc" ]]; then
+ source .envrc
+ fi
+ '';
+}