aboutsummaryrefslogtreecommitdiffhomepage
path: root/devenv.nix
diff options
context:
space:
mode:
Diffstat (limited to 'devenv.nix')
-rw-r--r--devenv.nix49
1 files changed, 14 insertions, 35 deletions
diff --git a/devenv.nix b/devenv.nix
index 81eff5a..02cca28 100644
--- a/devenv.nix
+++ b/devenv.nix
@@ -1,55 +1,34 @@
-# profile.nix
-{ pkgs ? import <nixpkgs> { }, name ? "user-env" }: with pkgs;
+{ pkgs ? import <nixpkgs> { }, name ? "user-env" }:
+with pkgs;
buildEnv {
inherit name;
- extraOutputsToInstall = [ "out" "man" "lib" ]; # to get all needed symlinks
+ extraOutputsToInstall = [ "out" "man" "lib" ]; # to get all needed symlinks
paths = [
+ # ❯❯❯ nix_related
#nix # if not on NixOS, this is needed
direnv
+ #cachix
nixVersions.unstable #nixFlakes
nix-prefetch-git
validatePkgConfig
- nix-tree jq nix-output-monitor
+ nix-output-monitor
+ nix-tree
+ jq
git
+ gnumake
ps
- ### d_build_related
+ # ❯❯❯ d_build_related
+ # ❯❯ package manager
dub
- ## compiler
+ # ❯❯ compiler
dmd
ldc
- #gdc
- #rund
- ## linker
- #lld
- #mold
- ## builder
- #ninja
- #meson
- ### sqlite search related
+ # ❯❯❯ sqlite search related
sqlite
- # ### pdf_latex_related
- # source-sans-pro
- # source-serif-pro
- # source-code-pro
- # texlive.combined.scheme-full
- # ### xml_and_epub_related
- # libxml2
- # html-tidy
- # xmlstarlet
- # epubcheck
- # ebook_tools
- # epr
- # sigil
- # calibre #(suite includes: ebook-viewer)
- # foliate
- # ### i18n translation related
- # perl534Packages.Po4a
- ### candy
- #starship
# this will create a script that will rebuild and upgrade your setup; using shell script syntax
(writeScriptBin "nix-rebuild" ''
#!${stdenv.shell}
- cd <path-to-flake> || exit 1
+ #cd <path-to-flake> || exit 1
nix flake update
nix profile upgrade '.*'
'')