aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix84
1 files changed, 43 insertions, 41 deletions
diff --git a/flake.nix b/flake.nix
index 9e132d5..04663db 100644
--- a/flake.nix
+++ b/flake.nix
@@ -39,7 +39,7 @@
inherit shell;
inherit devEnv;
buildInputs = [ sqlite ];
- nativeBuildInputs = [ dub dmd ldc gdc gnumake ]; # [ dub dmd ]; [ dub ldc ]; [ dub gdc ];
+ nativeBuildInputs = [ dub ldc gnumake ]; # [ dub dmd ]; [ dub ldc ]; [ dub gdc ];
buildPhase = ''
runHook preBuild
for DC_ in dmd ldmd2 ldc2 gdc gdmd; do
@@ -94,25 +94,25 @@
inherit installPhase;
inherit postInstall;
};
- spine-gdc = stdenv.mkDerivation {
- inherit pname;
- inherit version;
- meta.mainProgram = "spine-gdc";
- executable = true;
- src = self;
- inherit shell;
- inherit devEnv;
- buildInputs = [ sqlite ];
- nativeBuildInputs = [ dub gdc gnumake ];
- buildPhase = ''
- runHook preBuild
- dub build --compiler=$(type -P gdc) --build=gdc --combined --skip-registry=all
- runHook postBuild
- '';
- inherit checkPhase;
- inherit installPhase;
- inherit postInstall;
- };
+ #spine-gdc = stdenv.mkDerivation {
+ # inherit pname;
+ # inherit version;
+ # meta.mainProgram = "spine-gdc";
+ # executable = true;
+ # src = self;
+ # inherit shell;
+ # inherit devEnv;
+ # buildInputs = [ sqlite ];
+ # nativeBuildInputs = [ dub gdc gnumake ];
+ # buildPhase = ''
+ # runHook preBuild
+ # dub build --compiler=$(type -P gdc) --build=gdc --combined --skip-registry=all
+ # runHook postBuild
+ # '';
+ # inherit checkPhase;
+ # inherit installPhase;
+ # inherit postInstall;
+ #};
#vendorSha256 = "sha256-0Q00000000000000000000000000000000000000000=";
});
apps = forAllSystems (system: {
@@ -155,24 +155,24 @@
#export spineSqlite="spine --very-verbose --sqlite-update --sqlite-db-path=\"$SpineDBpath\" --sqlite-db-filename=\"spine.search.db\" --output=\"\$SpineOUT\" $SpinePOD/*"
'';
in with pkgs; {
- devShell = mkShell rec {
- name = "spine dev shell default";
+ devShell = mkShell {
+ name = "spine base dev shell";
inherit shell;
inherit devEnv;
#buildInputs = [ sqlite ];
#nativeBuildInputs = [ dub dmd ldc gdc gnumake ];
packages = [
sqlite
- dub dmd ldc gdc gnumake
+ dub dmd ldc gnumake
];
inherit shellHook;
};
- devShell-epub = mkShell rec {
- name = "spine dev shell for epub output";
+ devShell-epub = mkShell {
+ name = "spine dev shell for epub output";
inherit shell;
inherit devEnv;
- packages = [
- dub dmd ldc gdc gnumake
+ packages = [
+ dub dmd ldc gnumake
sqlite
libxml2
html-tidy
@@ -191,22 +191,22 @@
];
inherit shellHook;
};
- devShell-html = mkShell rec {
- name = "spine dev shell for latex & pdf output";
+ devShell-html = mkShell {
+ name = "spine dev shell for latex & pdf output";
inherit shell;
inherit devEnv;
- packages = [
- dub dmd ldc gdc gnumake
+ packages = [
+ dub dmd ldc gnumake
sqlite
];
inherit shellHook;
};
- devShell-latex-pdf = mkShell rec {
- name = "spine dev shell for latex & pdf output";
+ devShell-latex-pdf = mkShell {
+ name = "spine dev shell for latex & pdf output";
inherit shell;
inherit devEnv;
- packages = [
- dub dmd ldc gdc gnumake
+ packages = [
+ dub dmd ldc gnumake
sqlite
source-sans-pro
source-serif-pro
@@ -215,26 +215,28 @@
];
inherit shellHook;
};
- devShell-sqlite = mkShell rec {
- name = "spine dev shell for latex & pdf output";
+ devShell-sqlite = mkShell {
+ name = "spine dev shell for latex & pdf output";
inherit shell;
inherit devEnv;
- packages = [
- dub dmd ldc gdc gnumake
+ packages = [
+ dub dmd ldc gnumake
sqlite
];
inherit shellHook;
};
devShell-i18n = mkShell {
+ name = "spine dev shell internationalization, po4a";
inherit shell;
inherit devEnv;
- packages = [
- dub dmd ldc gdc gnumake
+ packages = [
+ dub dmd ldc gnumake
sqlite
perl534Packages.Po4a
];
inherit shellHook;
};
+ default = import ./shell.nix { inherit pkgs; };
});
};
}