aboutsummaryrefslogtreecommitdiffhomepage
path: root/nixDevEnv/shells/dmd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixDevEnv/shells/dmd.nix')
-rw-r--r--nixDevEnv/shells/dmd.nix23
1 files changed, 15 insertions, 8 deletions
diff --git a/nixDevEnv/shells/dmd.nix b/nixDevEnv/shells/dmd.nix
index f3d126c..0c68cc0 100644
--- a/nixDevEnv/shells/dmd.nix
+++ b/nixDevEnv/shells/dmd.nix
@@ -1,10 +1,17 @@
-{ pkgs ? import <nixpkgs> { overlays = [ (import ../overlays/dmdVersion.nix) ]; } }:
- pkgs.mkShell {
- buildInputs = with pkgs; [
- dub
- ninja
- dmd
- sqlite
- validatePkgConfig
+{ pkgs ? import <nixpkgs> { overlays = []; } }:
+let
+ dub2nix-src = fetchTarball {
+ url = "https://github.com/lionello/dub2nix/archive/master.tar.gz";
+ };
+ dub2nix = (import dub2nix-src) { inherit pkgs; };
+in pkgs.mkShell {
+ buildInputs = with pkgs; [
+ nix
+ dub
+ dmd
+ rdmd
+ sqlite
+ dub2nix
+ nix-prefetch-git
];
}