aboutsummaryrefslogtreecommitdiffhomepage
path: root/project.nix
diff options
context:
space:
mode:
Diffstat (limited to 'project.nix')
-rwxr-xr-xproject.nix40
1 files changed, 0 insertions, 40 deletions
diff --git a/project.nix b/project.nix
deleted file mode 100755
index bfd44fb..0000000
--- a/project.nix
+++ /dev/null
@@ -1,40 +0,0 @@
-#!/usr/bin/env -S nix-build
-{ pkgs ? import <nixpkgs> {} }:
-with import ./nix/mkDub.nix { inherit pkgs; };
-mkDubDerivation rec {
- name = "spine-${version}";
- version = "0.11.3";
- src = ./.;
- buildInputs = [
- pkgs.sqlite
- (
- let
- dub2nix-src = ./src/build_depends/dub2nix/.;
- dub2nix = (import dub2nix-src) { inherit pkgs; };
- in
- with pkgs; [
- nixFlakes
- rund
- dub
- ldc
- sqlite
- nix-prefetch-git
- validatePkgConfig
- jq
- git
- ]
- )
- ];
- # buildPhase = [ ];
- installPhase = ''
- install -m755 -D spine $out/bin/spine
- echo "built $out/bin/spine"
- '';
- meta = with pkgs.lib; {
- homepage = https://sisudoc.org;
- description = "a sisu like document parser";
- license = licenses.agpl3Plus;
- platforms = platforms.linux;
- maintainers = [ RalphAmissah ];
- };
-}