aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix14
1 files changed, 13 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index 445e0b1..a426e51 100755
--- a/shell.nix
+++ b/shell.nix
@@ -1,7 +1,19 @@
{ pkgs ? import <nixpkgs> {} }:
pkgs.mkShell {
buildInputs = with pkgs; [
- (import ./nix/pkglst/shell-pkgs.nix { inherit pkgs; })
+ (
+ with pkgs; [
+ nixFlakes
+ rund
+ dub
+ ldc
+ sqlite
+ nix-prefetch-git
+ validatePkgConfig
+ jq
+ git
+ ]
+ )
];
shellHook = ''
if [[ -e ".envrc" ]]; then