aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix131
1 files changed, 66 insertions, 65 deletions
diff --git a/shell.nix b/shell.nix
index 98902e2..a86bb78 100755
--- a/shell.nix
+++ b/shell.nix
@@ -1,71 +1,72 @@
#!/usr/bin/env -S nix-shell --pure
#!nix-shell -i bash
-{ pkgs ? import <nixpkgs> {} }:
+{pkgs ? import <nixpkgs> {}}:
with pkgs;
-mkShell {
- buildInputs = [
- # ❯❯❯ nix_related
- #nix
- direnv
- #cachix
- nixVersions.unstable #nixFlakes
- nix-prefetch-git
- validatePkgConfig
- nix-output-monitor
- nix-tree
- jq
- git
- gnumake
- ps
- # ❯❯❯ d_build_related
- # ❯❯ package manager
- dub
- # ❯❯ compiler
- ldc
- #rund
- # ❯❯ linker
- #lld
- #mold
- # ❯❯ builder
- #ninja
- #meson
- # ❯❯❯ sqlite search related
- sqlite
- # ❯❯❯ pdf_latex_related
- # source-sans-pro
- # source-serif-pro
- # source-code-pro
- # texlive.combined.scheme-full
- # ❯❯❯ xml_and_epub_related
- # libxml2
- # html-tidy
- # xmlstarlet
- # epubcheck
- # ebook_tools
- # epr
- # sigil
- # calibre #(suite includes: ebook-viewer)
- # foliate
- # ❯❯❯ i18n translation related
- # perl534Packages.Po4a
- ];
- shellHook = ''
- nix flake update
- nix flake check
- nix flake show
- echo '
- shell.nix echo ❯❯
+ mkShell {
+ buildInputs = [
+ # ❯❯❯ nix_related
+ #nix
+ direnv
+ nixVersions.unstable #nixFlakes
+ nix-prefetch-git
+ validatePkgConfig
+ nix-output-monitor
+ nix-tree
+ jq
+ alejandra
+ git
+ # ❯❯❯ dev
+ gnumake
+ ps
+ # ❯❯❯ d_build_related
+ # ❯❯ package manager
+ dub
+ # ❯❯ compiler
+ ldc
+ #rund
+ # ❯❯ linker
+ #lld
+ #mold
+ # ❯❯ builder
+ #ninja
+ #meson
+ # ❯❯❯ sqlite search related
+ sqlite
+ # ❯❯❯ pdf_latex_related
+ # source-sans-pro
+ # source-serif-pro
+ # source-code-pro
+ # texlive.combined.scheme-full
+ # ❯❯❯ xml_and_epub_related
+ # libxml2
+ # html-tidy
+ # xmlstarlet
+ # epubcheck
+ # ebook_tools
+ # epr
+ # sigil
+ # calibre #(suite includes: ebook-viewer)
+ # foliate
+ # ❯❯❯ i18n translation related
+ # perl534Packages.Po4a
+ ];
+ shellHook = ''
+ nix flake update
+ nix flake check
+ nix flake show
+ echo '
+ shell.nix echo ❯❯
- ❯❯ nix flake update && nix flake check --show-trace && nix flake show && nix develop ".#devShell" -c zsh
+ ❯❯ nix flake update && nix flake check --show-trace && nix flake show && nix develop ".#devShell" -c zsh
- ❯❯ nix develop
- ❯❯ nix develop -c zsh
+ ❯❯ nix develop
+ ❯❯ nix develop -c zsh
- ❯❯ nix build
- ❯❯ nix build ".#default" --print-build-logs
- ❯❯ nix build ".#spine-dmd" --print-build-logs |& nom
- ❯❯ nix build ".#spine-ldc" --print-build-logs |& nom
- ❯❯ nix build ".#spine-gdc" --print-build-logs |& nom
- '
- '';
-}
+ ❯❯ nix build
+ ❯❯ nix build ".#default" --print-build-logs
+ ❯❯ nix build ".#spine-dmd" --print-build-logs |& nom
+ ❯❯ nix build ".#spine-ldc" --print-build-logs |& nom
+ ❯❯ nix build ".#spine-gdc" --print-build-logs |& nom
+ '
+ '';
+ }